inris088
?>

Составить программу нахождения s всех граней куба, объема куба и среднее арифметическое n чисел

Информатика

Ответы

Voronin-Albertovich
Жили – были в лесу: Заяц, Лиса, Волк и Медведь. Как-то раз, весной, после зимней спячки встал медведь и говорит: «Я опять выспаться не успел». Лесные жители давай над ним смеяться. Медведю это не понравилось, и он ушел. Стал он придумывать, как бы им отомстить. Ходил он, ходил, думал, думал и придумал. Зайца он решил испугать, когда он в школу пойдёт, чтобы забыл он туда дорогу. У Лисы своровал деньги, чтобы она не ходила по магазинам, не модничала, и не зазнавалось. А Волка  решил подкараулить, поймать и посадить в клетку.

некоторое время. И вот идёт Заяц, а навстречу ему Лиса. Спрашивает Лиса у него: «Ты что такой грустный». А он ей отвечает: «Да меня Медведь пугает, и теперь я не могу в школу ходить», А Лиса говорит: «И  у меня неприятность». Заяц спрашивает: «Что случилась?». А она ему: «У меня деньги пропали». Заяц говорит Лисе: «Может это Медведь украл?». Они подумали, почему  не видать Волка. Лиса: «Может он заболел». Заяц: «Ну,  пойдём, сходим к нему, посмотрим, что он делает». И вот они пришли, стучат в дверь, стучат, а им никто не открывает. Тогда они стали переживать и пошли на поиски. Но Волка было не слыхать.

 Решили они сходить к Мудрой Сове. Всё ей рассказали, какие у них неприятности – что натворил Медведь. Мудрая Сова решила вызвать Медведя на лесной совет и убедить его, что он не прав в своих поступка. Вот вызвали Медведя на лесной совет. И стали убеждать его в том, что у каждого есть свои права. Каждый имеет право на образование, поэтому Заяц должен учиться. Каждый имеет право на свободное передвижение, на пользование денежными единицами, а также на право свободного выбора и на личную собственность. Каждый имеет право на свободу, на личную неприкосновенность, а самое главное право на жизнь. Медведю рассказали много всяких прав и убедили его в том, что никто не должен нарушать эти права.  Медведь подумал и решил, что он поступил не правильно и не красиво. Решил он исправить свои ошибки: пришёл к Лисе и отдал деньги, Зайца больше не стал пугать, Волка выпустил на волю. Лесные жители извинились перед Медведем за то, что они над ним смеялись. Медведь тоже извинился за свои поступки.

 Стали они жить дружно и не ссориться. Потому что  каждый знал свои права и  их не нарушал. Так если стал мир и покой в лесу, то, как нам, людям, не знать свои права и обязанности, и их не выполнять? Стыдно!
gorsimonyan4
Какое-то запутанное условие.
Решение "в лоб", без оптимизаций:

Procedure Razmen(a : Integer);
Begin
  If a>=500 then
  Begin
    Writeln('500 - ',a div 500);
    Razmen(a-(a div 500)*500);
  end
  else
    If a>=100 then
    Begin
      Writeln('100 - ',a div 100);
      Razmen(a-(a div 100)*100);
    end
    else
      If a>=50 then
      Begin
        Writeln('50 - ',a div 50);
        Razmen(a-(a div 50)*50);
      end
      else
        If a>=10 then
        Begin
          Writeln('10 - ',a div 10);
          Razmen(a-(a div 10)*10);
        end
        else
          If a>=5 then
          Begin
            Writeln('5 - ',a div 5);
            Razmen(a-(a div 5)*5);
          end
          else Writeln('1 - ',a);
end;
Begin
  Razmen(1530);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу нахождения s всех граней куба, объема куба и среднее арифметическое n чисел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kiravalter1998697
sergeylive
Иван1764
nsmirnova
A2017
andreich97
Abdulganieva1367
st-op767840
Юрий197
sadkofamily61
artem-whitenoise142
yna21289
Станиславович1830
varvara-kulkova
Serkova_Elena251