#include <iostream>
#include <cstdlib>
#include <ctime>
int main()
{
std::srand(std::time(NULL));
unsigned short int
number,
value,
_value,
correct = 0;
std::cout << "Введите число, умножение на которое будет происходить, и кол-во вопросов: ";
std::cin >> number >> value;
_value = value;
while(_value > 0)
{
unsigned int
_number,
tmp = 1 + std::rand() % 10;
std::cout << number << " * " << tmp << " = ";
std::cin >> _number;
if(_number == tmp * number)
{
std::cout << "Верно." << std::endl;
correct++;
}
_value--;
}
std::cout << "Процентное соотношение: " << 100 * (static_cast<float>(correct) / value) << "%."
<< std::endl;
}
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу в паскаль находящую у при условиях. у=х2, если х> 0, у=5, если х=10, у=х2, если х< 10
2. в.пиксель
3. а.красный, синий, зеленый
4. а.хранения информации о цвете каждого пикселя экрана монитора
5. г.программа для создания и редактирования рисунков
6. б.графических примитивов
7.б. растровой графики
8. а.электронное устройство для хранения двоичного кода изображения, выводимого на экран
9. а.дисплейный процессор и видеопамять(немного есть сомнения)
10. в. bmp
11.Разрешающая сканера 300 dpi (dot per inch - точек на дюйм) означает, что на отрезке длиной 1 дюйм сканер различить 300 точек.
Переведем разрешающую сканера из точек на дюйм (1 дюйм = 2,54 см) в точки на сантиметр:
300dpi : 2,54 ≈ 118 точек/см.
Следовательно, размер изображения в точках составит
25*118 и 30*118 = 2950х3540
Общее количество точек изображения равно:
2950 * 3540 = 10 443 000.
Информационный объем файла равен:
3 байта= 24 бита. 24 * 10 443 000 = 250632000 бит = 31329000 байт = 30595 Кб ≈ 30 Мб
12.65536 означает, что на каждый пиксель отводится два байта. Итого имеем 1280*2КБ=2,5МБ.