diana-kampoteks
?>

Задан вектор p. напишите программу вычисления отношения произведения положительных элементов вектора к сумме элементов, больших арифметического среднего всех значений. решите в паскале

Информатика

Ответы

Yelizaveta555

сочинение на тему «информатика в нашей жизни»

информатика – современная область знаний. мы изучаем ее в школе, как предмет, но не только. зачем нужна информатика? в современном мире мы каждый день сталкиваемся с новейшими технологиями. у меня дома есть компьютер, подключенный к интернету. когда я ищу что-нибудь в интернете или пишу другу сообщение, то использую достижения информатики.

вокруг нас – море информации, а наука информатика как раз решает вопросы, как этим морем. поэтому она и носит такое название. без достижений информатики не существовало бы компьютеров, интернета и других новых технологий, которые уже стали для нас привычны. не было бы даже вычислительных машин, которые могут производить сложные расчеты за доли секунды. а расчеты нужны везде: на производстве, в банках, на линиях транспорта. жизнь была бы намного сложнее, если бы информатика не развилась до такого уровня, как сейчас.

не было бы поисковых систем, с которых сейчас можно отыскать нужны информацию. я не говорю, что можно найти любую информацию о любом человеке, потому что в мире всегда остаются тайны и секреты. но большинство информации, полезной в учебе и повседневной жизни, найти можно. ну, и море всякого интересного тоже. еще лет двадцать назад для этого пришлось бы идти в библиотеку и рыться там полдня.

возникает вопр�с, зачем изучать информатику всем школьникам? ведь далеко не все станут программистами, системными администраторами, веб-дизайнерами? наверное, смысл этого в том, чтобы все понимали, с чем они сталкиваются каждый день, как это действует. ведь не зря наше время называется информационной эпохой.

Katkova

Задания 4 и 5:

Задание 4:

static void Main(string[] args)

       {

           int N = 10, count, sum = 0;

           int[] mas = new int[N];

           Random rnd = new Random();

           for (int i = 0; i < N; i++)

           {

               mas[i] = rnd.Next(0, 10);

           }

           Console.WriteLine("Массив: ");

           for (int i = 0; i < N; i++)

           {

               Console.Write(String.Format("{0,4}", mas[i]));

           }

           Console.WriteLine();

           Console.WriteLine();

           Console.Write("Введите количество элементов для суммирования (n): ");

           count = Convert.ToInt32(Console.ReadLine());

           if (count > N)

           {

               count = N;

               Console.WriteLine();

               Console.Write("Количество элементов не должно превышать размерность массива.");

           }

           for (int i = 0; i < count; i++)

           {

               sum += mas[i];

           }

           Console.WriteLine();

           Console.Write("Сумма первых " + count + " элементов массива = " + sum);

           Console.ReadKey();

       }

Задание 5:

static void Main(string[] args)

       {

           int N = 10, x, y, sum = 0;

           int[] mas = new int[N];

           Random rnd = new Random();

           for (int i = 0; i < N; i++)

           {

               mas[i] = rnd.Next(0, 10);

           }

           Console.WriteLine("Массив: ");

           for (int i = 0; i < N; i++)

           {

               Console.Write(String.Format("{0,4}", mas[i]));

           }

           Console.WriteLine();

           Console.WriteLine();

           Console.Write("Введите x: ");

           x = Convert.ToInt32(Console.ReadLine());

           Console.Write("Введите y: ");

           y = Convert.ToInt32(Console.ReadLine());

           if (x > N)

           {

               x = N / 2;

           }

           if (y > N)

           {

               y = N;

           }

           if (y < x)

           {

               x = N / 2;

               y = N;

               Console.WriteLine();

               Console.Write("x не должен быть больше y.");

           }

           for (int i = x - 1; i < y; i++)

           {

               sum += mas[i];

           }

           Console.WriteLine();

           Console.Write("Сумма элементов массива, с " + x + " элемента по " + y + " равна " + sum);

           Console.ReadKey();

       }

Объяснение:

Задания 4 и 5 на языке C#.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задан вектор p. напишите программу вычисления отношения произведения положительных элементов вектора к сумме элементов, больших арифметического среднего всех значений. решите в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ievlevasnezhana7
kadrevproduction
magazintrofey
natakrechko
chumakanna17
Tane4ka2110
Sonyamaslo6
Vladstreletskiy
Olybetezina1973
kirycha-2000719
vikola2008
katrin50
Артур1807
ilez03857
bochkarevazh