maxborod
?>

нужно написать программу на javascript. строка состоит из слов, разделенных одним или несколькими пробелами. поменяйте местами наибольшее по длине слово и наименьшее.

Информатика

Ответы

Алексей Ксения

А)

program num;

var

 number: integer;

begin

 read(number);

 if (number mod 2 = 0) then

   write('ДА')

 else

   write('НЕТ');

end.

Б)

program b;

var

 first, second: integer;

begin

 read(first, second);

 if (first > second) then

   write(first + second)

 else

   write(first * second);

end.

Объяснение:

А)

program num; // Название программы

var

 number: integer; // Целочисленная переменная, хранящая вводимое с клавиатуры число

begin // Начало программы

 read(number); // Считываем число с клавиатуры

 if (number mod 2 = 0) then // Если остаток от деления значения переменной number на 2 = 0, тогда

   write('ДА') // Выводим "Да"

 else // Иначе

   write('НЕТ'); // Выводим "Нет"

end. // Конец  программы

Б)

program b; // Название программы

var

 first, second: integer; // Целочисленные переменные, хранящие вводимые с клавиатуры числа

begin // Начало программы

 read(first, second); // Считываем числа с клавиатуры

 if (first > second) then // Если первое число > второго числа, тогда

   write(first + second) // Выводим сумму этих чисел

 else // Иначе

   write(first * second); // Выводим произведение этих чисел

end. // Конец  программы

Pokupatel

Рассмотрим множество Компьютерные объекты. Подмножествами являются Устройства, Файлы, Связи, Контейнеры. Каждое подмножество будем рассматривать по отдельности.

Множество Устройства включает в себя всё то, из чего состоит наш компьютер. Здесь мы можем выделить два подмножества: системный блок и периферийные устройства. Во множество системный блок входит все, что в нем находится. Например, процессор, блок питания, материнская плата, жёсткий диск и так далее.  Во множество периферийные устройства входят монитор, клавиатура, мышь, принтер, колонки, сканер и так далее.

Вернёмся к множеству Файлы. В них входят файлы программ и документы.

Множество Связи включает в себя значки и ярлыки, так как через них запускаются программы, открываются документы или папки и прочее.

Множество контейнеры. Сюда входят Папки, окна, панель Управления, так как они содержат в себе какие-либо элементы. Например, в папках, как вы уже знаете, могут содержаться файлы и другие папки.

Каждый человек может классифицировать компьютерные объекты по-разному, составляя классификацию, удобную для себя.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужно написать программу на javascript. строка состоит из слов, разделенных одним или несколькими пробелами. поменяйте местами наибольшее по длине слово и наименьшее.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

АЛЕКСЕЙ
arbekova
Сергеевич1396
Wunkamnevniki13438
Евгеньевич Балиловна1398
ea9824165833886
Анна1417
windless-el
Boyaris
TrofimovAnastasiya828
ilds88
Serezhkin
vladexi
Глазкова633
Баканова1415