funny-furiya
?>

1. интерпретатор распознаёт команды в исходном тексте программы и исполняет их. 2. меньше всего места в памяти занимают переменные логического типа. 3. команды программы всегда исполняются именно в том порядке, в каком они записаны в памяти. 4. ascii-код символа помещается в переменную типа byte. 5. в тип string могут быть преобразованы значения переменных любых типов. 6. скомпилированная программа выполняется быстрее, чем программа, выполняемая интерпретатором. 7. строка не может иметь длину меньше двух символов, иначе она превращается в переменную типа char. 8. размер памяти, занимаемой переменной типа single, зависит от значения этой переменной. 9. имена переменных существуют только в исходном тексте программы, а в машинном коде к данным обращаются по адресам. 10. название месяца - значение типа string, а его номер можно поместить в переменную типа byte. : везде обозначить верно утверждение или нет.

Информатика

Ответы

Strelkov567
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication5
{
    class Program
    {
        static void Main(string[] args)
        {
            // 1) Написать программу,которая вводит таблицу квадратов первых 10 чисел.
            for (int i = 1; i <= 10; i++)
            {
                Console.WriteLine(i + "^2=" + Math.Pow(i, 2));
            }

            Console.ReadKey();

            // 2) Найти все натуральные числа а,b,с, из интервала от 1 до 10 для которых выполняется равенство а^2+b^2=c^2

            for (int a = 1; a <= 10; a++)
            {
                for (int b = 1; b <= 10; b++)
                {
                    for (int c = 1; c <= 10; c++)
                    {
                        if (Math.Pow(a, 2) + Math.Pow(b, 2) == Math.Pow(c, 2))
                            Console.WriteLine("a=" + a + "; b=" + b + "; c="+c);
                    }
                }
            }

            Console.ReadKey();
        }
    }
}
zrs-546

Програ́ммное обеспе́чение[1][2] (допустимо также произношение обеспече́ние[3][4][5]) (ПО) — все или часть программ, процедур, правил и соответствующей документации системы обработки информации ИЛИ

Совокупность программ системы обработки информации и программных документов[8], необходимых для эксплуатации этих программ 

Программное обеспечение принято по назначению подразделять на системное, прикладное и инструментальное, а по распространения и использования на несвободное (закрытое), открытое и свободное.

 

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. интерпретатор распознаёт команды в исходном тексте программы и исполняет их. 2. меньше всего места в памяти занимают переменные логического типа. 3. команды программы всегда исполняются именно в том порядке, в каком они записаны в памяти. 4. ascii-код символа помещается в переменную типа byte. 5. в тип string могут быть преобразованы значения переменных любых типов. 6. скомпилированная программа выполняется быстрее, чем программа, выполняемая интерпретатором. 7. строка не может иметь длину меньше двух символов, иначе она превращается в переменную типа char. 8. размер памяти, занимаемой переменной типа single, зависит от значения этой переменной. 9. имена переменных существуют только в исходном тексте программы, а в машинном коде к данным обращаются по адресам. 10. название месяца - значение типа string, а его номер можно поместить в переменную типа byte. : везде обозначить верно утверждение или нет.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

universal21vek116
Bni1504
ludakamasana
georgegradoff122
dzo-dzo
deadnobody
Shevtsov1818
Usynin-nikolay
vikanikita
mstapottery
Петренко1852
Filintver
boykovandrew6663
mel9152480522
tatianaavoronina66