Объяснение:
program matic1;
const z=100;
type mas=array[1..z] of integer;
type mas2=array[1..z,1..z] of integer;
var
u :mas2;
u1, u2: mas;
n,k,m:integer;
procedure ch1(n:integer);
var i,j:integer;
begin
j:=0;k:=0;m:=0;
randomize;
for i:=1 to n do
for j:=1 to n do
u[i,j]:= random(20+j)+20;
for i:=1 to n do
for j:=1 to n do
begin
if j>=i then begin k:=k+1;u1[k]:=u[i,j] end
else begin m:=m+1;u2[m]:=u[i,j] end;
end;
end;
// Вывод 2 мерного массива на экран
// a -массив n-размер,text - что хотим написать
procedure showmas2(b:mas2;n:integer;text:string);
var
i,j:integer;
begin
writeln(text);
for i:=1 to n do
for j:=1 to n do
if j<>n then write(b[i,j],' ') else writeln(b[i,j],' ');
readln;
end;
// Вывод 1 мерного массива на экран
// a -массив nn-размер,text - что хотим написать
procedure showmas(b:mas;nn:integer;text:string);
var
i:integer;
begin
writeln(text);
for i:=1 to nn do
write(b[i],' ');
readln;
end;
begin
Write('Введите размер массива N= ');
readln(n);
ch1(n);
showmas2(u,n,'Исходная матрица NxN u');
showmas(u1,k,'Элементы главной диагонали и выше u1');
showmas(u2,m,'Элементы ниже главной диагонали u2');
readln;
end.
end.
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу, которая имитирует работу калькулятора. работе делается в visual studio.
C#
using System;
namespace ArrayMax
{
class Program
{
static void Main(string[] args)
{
int n;
Console.WriteLine("Введите количество элементов массива: ");
n = Convert.ToInt32(Console.ReadLine()); //вводим количество элементов Массива
Console.WriteLine();
int[] a = new int[n]; //выделяем память под массив
Random r = new Random();
for (int i = 0; i < n; i++)
{
a[i] = r.Next(0, 20); //заполняем массив рандомными числами от 0 до 20
}
for (int i = 0; i < n; i++)
{
Console.WriteLine(a[i]); //выводим массив
}
int max = a[0], maxIndex = 0;
for (int i = 0; i < n; i++)
{
if (max < a[i])
{
max = a[i];
maxIndex = i; //находим индекс максимального элемента
}
}
int count = 0; //счётчик для чисел между 1 и 12 до макс элемента
for (int i = 0; i <= maxIndex; i++)
{
if (a[i] >= 1 && a[i] <= 12) //если элемент >= 1 и <= 12, прибавляем счётчик
count++;
}
Console.WriteLine();
Console.WriteLine(count); //выводим количество числе от 1 до 12 до макс эл массива
Console.ReadKey();
}
}
}