Елена
?>

Напишите на языке питон программу, которая считывает слово, затем выводит: «[это слово] ? конечно, помню, ведь мы проходили это на занятии! ».

Информатика

Ответы

Алена

n = input()

print( n+ "? Конечно, помню, ведь мы проходили это на занятии!")

dmdlir
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.

var
  n,s,t,i:integer;
begin
  Write('Укажите количество данных: ');
  Read(n);
  Writeln('Теперь вводите данные');
  s:=0;
  for i:=1 to n do
    begin
    Read(t);
    s:=s+t
    end;
  Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.

Пример решения

Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4
pizniak

Решал на паскале. 

Первая:
var i:integer; s:string; a:array[1..3] of integer; t.q,z: boolean;
begin
readln(i); q:=false; t:=false;
a[1]:=i mod 10;
a[2]:=i div 10 mod 10;
a[3]:=i div 10 div 10;
for i:=1 to 3 do

begin
if a[i]=4 then

q:=true;

if (a[i]=7) and (q=true) then t:=true;

if a[i]=7 then z:=true;

end; 

if t=true then writeln('Vhodyat oba) else if (q=true) and (z=false) then writeln('Vhodit 4') else if (q=false) and (z=true) then writeln('Vhodut 7');
readln;
end.

 

 

Вторая:
var a,b,c,min:integer;
begin
min:=32000;
readln(a,b,c);
if a<min then min:=a; if b<min then min:=b; if c<min then min:=c;
writeln ('Minimalnoe - ',min);
readln;
end.

 

 

Третья:

var a,b,c:integer; x,y,d:real;

begin
readln(a,b,c);
d:=b*b-(4*a*c);

if d=0 then
begin
x:=(-b/2*a);
writeln('One root: ',x:0:0);
end;

if d>0 then
begin
x:=(-b+sqrt(d))/2*a;
y:=(-b-sqrt(d))/2*a;
if y>x then
writeln('Two roots: ',x:0:0,' ',y:0:0) else writeln('Two roots: ',y:0:0,' ',x:0:0);
end;

if d<0 then writeln('No roots');
readln;
end.:

 

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите на языке питон программу, которая считывает слово, затем выводит: «[это слово] ? конечно, помню, ведь мы проходили это на занятии! ».
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zamkova836
RozaAsadullina
Ferrigen
asi19776
allaraygor
Ни Дмитрий1095
ak74-81
vera141187
vadimkayunusov
alex13izmailov
lider123
Yelena_Gennadevna
Klicheva_Ermachenkova1536
vodexshop2
Tatgri