Тоноян
?>

15 условие напишите программу, которая узнаёт у человека его возраст и сообщает, кто он: малыш (до 6 лет), школьник (от 7 до 17 лет), взрослый (от 18 до 64 лет), аксакал (от 65 до 120 лет) или привидение (всё остальное формат входных данных вводится целое число n (0≤n≤231−1). формат выходных данных требуется вывести «baby», «schoolchild», «adult», «elder» или «ghost» соответсвенно для малыша, школьника, взрослого, аксакала или привидения.

Информатика

Ответы

Людмила Анна

программа: сканер. можно так сказать. и ты не 15 даёшь а 8))

Avdeeva Inga1505

Программа работает с учётом того, что если первый элемент отрицательный, то он умножается сам на себя и потом все последующие элементы умножаются уже на новый первый элемент в массиве, который умножился сам на себя. Так что такие большие цифры обусловлены именно этим.

#include <iostream>

#include <time.h>

using namespace std;

void print_array(int** arr, int n, int m) {

for (size_t i = 0; i < n; i++) {

 for (size_t j = 0; j < m; j++) {

  cout << arr[i][j] << " ";

 }

 cout << endl;

}

cout << endl;

}

int** auto_input_matrix(int** arr, int n, int m) {

for (size_t i = 0; i < n; i++) {

 for (size_t j = 0; j < m; j++) {

  arr[i][j] = rand() % 200 - 100;

 }

}

return arr;

}

int** multiplying_negative_elements_of_an_array_by_the_first_element(int** arr, int n, int m) {

for (size_t i = 0; i < n; i++) {

 for (size_t j = 0; j < m; j++) {

  if (arr[i][j] < 0) {

   arr[i][j] = arr[i][j] * arr[i][0];

  }

 }

}

return arr;

}

int main() {

srand(time(NULL));

setlocale(LC_ALL, "Russian");

int n, m;

cout << "Введите количество строк в массиве: ";

cin >> n;

cout << "Введите количество элементов в массиве построчно: ";

cin >> m;

int** array = new int*[n];

for (size_t i = 0; i < n; i++) {

 array[i] = new int[m];

}

array = auto_input_matrix(array, n, m);

print_array(array, n, m);

array = multiplying_negative_elements_of_an_array_by_the_first_element(array, n, m);

print_array(array, n, m);

delete[] array;

}

dashkevich-76611

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

int main()

{

   const int n = 4;

   int a;

   int mas[n][n];

   srand(time(NULL));

   for (int i = 0; i < n; i++)

   {

       for (int j = 0; j < n; j++)

       {

           a = rand() % 11 - 5 ;

           mas[i][j] = a;

          cout.width(3);

            cout <<mas[i][j] <<" ";

       }

        cout <<endl;

   }

   cout <<endl;

   

for (int i = 0; i < n; i++)

  {

   for (int j = 0; j < n; j++)

     {

     if (mas[i][j]<0){

       mas[i][j]=mas[i][j]*mas[i][0];

       

       }

       cout.width(3);

       cout <<mas[i][j] <<" ";

     }

     cout <<endl;

  }  

   

   

   return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

15 условие напишите программу, которая узнаёт у человека его возраст и сообщает, кто он: малыш (до 6 лет), школьник (от 7 до 17 лет), взрослый (от 18 до 64 лет), аксакал (от 65 до 120 лет) или привидение (всё остальное формат входных данных вводится целое число n (0≤n≤231−1). формат выходных данных требуется вывести «baby», «schoolchild», «adult», «elder» или «ghost» соответсвенно для малыша, школьника, взрослого, аксакала или привидения.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

maltes
soa8690
Бочкова_Елена203
ikhilovb76
merung
nsoro937
kabanovae
betepah
Ubuleeva826
donliolik
l250sp70
eleniloy26
avolodyaev
coleslow12
kapi30