Роман Александр66
?>

Составьте программу которая загружает из файлов и выводит на экран изображение животных, растений, памятников архитектуры.

Информатика

Ответы

Голубева1440

uses GraphABC;

var pic : integer;

begin

SetWindowSize (700, 750);

ClearWindow (clBlack);

SetFontSize(20);

pic:=LoadPicture('bohr.jpg');

DrawPicture (pic, 30, 30, 180, 200);

SetFontColor(clGreen);

TextOut(100,240,'Бор');

pic:=LoadPicture('Galileo.jpg');

DrawPicture (pic, 210, 230, 200, 230);

SetFontColor(clBrown);

TextOut(250,470,'Галилео');

pic:=LoadPicture('Einstein.jpg');

DrawPicture (pic, 30, 460, 180, 210);

SetFontColor(clRed);

TextOut(50,680,'Эйнштейн');

pic:=LoadPicture('Leonardo.jpg');

DrawPicture (pic, 410, 60, 180, 210);

SetFontColor(clBlue);

TextOut(440,280,'Леонардо');

pic:=LoadPicture('Newton.jpg');

DrawPicture (pic, 410, 400, 190, 210);

SetFontColor(clPurple);

TextOut(450,620,'Ньютон');

end.

Объяснение:

vdnh451
Onajonm: существует несколько типов оптических дисков: cd-диски – для записи и считывания информации с них используется инфракрасный лазер, на cd-диск может быть записано до 700 мбайт информации; dvd-диски – имеют значительно большую информационную емкость, чем сd-диски, так как для записи и считывания информации с них используется лазер с меньшей длиной волны и оптические дорожки на них имеют меньшую толщину и размещены более плотно. на одной стороне dvd-диска умещается 4,7 гбайт информации, но бывают диски двухслойные, тогда объем может достигать 8,5 гбайт. в оптических дисководах используется оптический принцип записи и считывания информации. информация на оптическом диске хранится на одной спиралевидной дорожке, идущей от центра диска к периферии и содержащей чередующиеся участки с плохой и хорошей отражающей способностью.
eizmaylova6
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая загружает из файлов и выводит на экран изображение животных, растений, памятников архитектуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Galinova2911
Ruslan Zarekovkin
esnails17
cheremetdiana
Сергеевич
Борисовна_Дмитриевич1003
ikavto6
sov0606332
Качкова1820
Oksana-Kirakosyan1301
Melnik Kaveshnikova1746
Belov
verachus
zoomagazinkotmatroskin
Kondratev Ruzavina22