зырянов_Юрьевна378
?>

только со старым. в новом не прокатит) нужно составить программу с модулем граф абц, нужно вставить башню и с башни типо падает яблоко анимацию сделать

Информатика

Ответы

lenarzhaeva

def rate_f(movies):

   if len(dictionary[movies]) == 0:

       return True

def film_in_dictionary(movies):

   if movies in dictionary:

       return True

   else:

       return False

def average(movies):

   mean = 0

   for key2 in dictionary[movies].keys():

       mean += dictionary[movies][key2]

   print(f'{movies} средняя оценка: {mean / len(dictionary[movies])}')

dictionary = {}

while True:

   command = input('Введите команду: ')

   if command != 'exit' and command != 'list' and command != 'add' and command != \

           'delete' and command != 'rate' and command != 'find':

       print('Error')

       continue

   if command == 'exit':

       break

   if command == 'list':

       for key in dictionary.keys():

           if rate_f(key):

               print(f'{key} не оценивался')

           else:

               average(key)

       continue

   film = input('Введите название фильма: ')

   if command == 'add':

       if film_in_dictionary(film):

           print('Error')

       else:

           dictionary[film] = {}

   elif command == 'delete':

       if film in dictionary:

           del dictionary[film]

       else:

           print('Error')

   elif command == 'rate':

       name = input('Имя пользователя: ')

       rate = float(input('Оценка: '))

       if 0 < rate <= 10:

           dictionary[film][name] = rate

       else:

           print('Error')

   elif command == 'find':

       if rate_f(film):

           continue

       for name, rate in dictionary[film].items():

           print(f'{name} поставил оценку: {rate}')

       average(film)

irina25095462

dictionary = {}

while True:

   command = input('Введите команду: ')

   if command != 'exit' and command != 'list' and command != 'add' and command !=  'delete' and command != 'rate' and command != 'find':

       print('Error')

       continue

   if command == 'exit':

       break

   if command == 'list':

       for key in dictionary.keys():

           average = 0

           if len(dictionary[key]) == 0:

               print(f'Фильм {key} не оценивался')

           else:

               for key1 in dictionary[key].keys():

                   average += dictionary[key][key1]

               print(f'{key} средняя оценка: {average / len(dictionary[key])}')

       continue

   film = input('Введите название фильма: ')

   if command == 'add':

       if film in dictionary:

           print('Error')

       else:

           dictionary[film] = {}

   elif command == 'delete':

       if film in dictionary:

           del dictionary[film]

       else:

           print('Error')

   elif command == 'rate':

       name = input('Имя пользователя: ')

       rate = float(input('Оценка: '))

       if 0 < rate <= 10:

           dictionary[film][name] = rate

       else:

           print('Error')

   elif command == 'find':

       if len(dictionary[film]) == 0:

           print('Фильм не оценивался')

           continue

       for name, rate in dictionary[film].items():

           print(f'{name} поставил оценку: {rate}')

       average = 0

       for key in dictionary[film].keys():

           average += dictionary[film][key]

       print(f'Средняя оценка: {average / len(dictionary[film])}')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

только со старым. в новом не прокатит) нужно составить программу с модулем граф абц, нужно вставить башню и с башни типо падает яблоко анимацию сделать
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Александрович784
dksvetlydir
Sergei_sergei
dg9792794674
Nugamanova-Tatyana840
rn3ay8
Никита227
denbelousov963
Vitalevich1187
Yelfimova-andrei
Aleksandrovna Kolesnik1764
lalaland2744
Chitaia
gbg231940
kim-1971