nat5555
?>

Напишите программу, которая считывает температуру в градусах цельсия и выводит "холодно", если температура меньше 15.5, "жарко", если температура больше 28, и "нормально" в остальных случаях. формат ввода одно число с плавающей точкой — температура. формат вывода одна строка — ответ на . пример 1 ввод вывод 28.6 жарко пример 2 ввод вывод 28 нормально язык питон

Информатика

Ответы

sn009

t=float(input())

If t>28:

print("Жарко")

elif t>15.5:

print("Нормально")

else:

print("Холодно")

Eduard Melikyan

Все роботы должны быть автономными (кроме класса управляемых  роботов).

● Робот не может существенно увеличиваться в размерах после начала

матча. Робот не должен разделяться на куски.

● Во время матча допустимым считается отделение от робота винтов,

гаек и других частей с общей массой менее 5 г.

● Перед соревнованием роботы должны пройти технический контроль.

● Каждый робот получает регистрационный номер. Номер размещается

на роботе для того, чтобы жюри и зрители могли идентифицировать

его.

Объяснение:

ainud
Const n=10; 
var a:array[1..n] of integer;
i,s,min:integer;
begin
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21)-10;
 write(a[i]:4);
 end;
writeln;
s:=0; 
min:=a[1];
for i:=1 to n do
 begin
 if a[i]>0 then s:=s+a[i];
 if a[i]<min then min:=a[i];
 end;
writeln('s = ',s,'   min = ',min);
for i:=1 to n do
 if a[i]>0 then a[i]:=s
  else if a[i]<0 then a[i]:=a[i]-min;
writeln('Измененный массив:');
for i:=1 to n do  write(a[i]:4);
writeln;
end.

Пример:
Исходный массив:
   9  -3  -5   7   1   5  -6   9  -8   7
s = 38   min = -8
Измененный массив:
  38   5   3  38  38  38   2  38   0  38

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая считывает температуру в градусах цельсия и выводит "холодно", если температура меньше 15.5, "жарко", если температура больше 28, и "нормально" в остальных случаях. формат ввода одно число с плавающей точкой — температура. формат вывода одна строка — ответ на . пример 1 ввод вывод 28.6 жарко пример 2 ввод вывод 28 нормально язык питон
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

matoksana
Lyalikova
dkedrin74038
shumilovs7252
olgaprevisokova302
Stanislavovna1237
shangina1997507
Gesper63
Ushakova Sakhno
AlekseiMardanova
svetrusval
turoverova5
dream2366
Nadirovich1317
koxhulya61