pronikov90
?>

Чебурек стоит а рублей и b копеек. голодный студент покупает n штук. пользователь вводит a, b и n. программа выводит, сколько рублей и копеек придётся заплатить за все чебуреки.например, для a=20, b=55 и n=2 получим 41 рубль и 10 копеек.нужно составить программу в паскале.​

Информатика

Ответы

vipteatr

  начало

                                                  делим на 2

                          есть остаток                               нет остатка

                          возводим в куб                         возводим в кводрат

                                                    конец        

allo22-27
1 задача
program proga;
var st,st2:string;
i:Integer;
begin
writeln('Введите число');
readln(st);
for i:=1 to length(st) do begin
st2:=st[i];
write(st2,' ');
end;
end.
2 задача
program proga2;
var st,st2:string;
i,a:Integer;
begin
writeln('Введите возраст');
readln(a);
if a>120 then
writeln('Неверные данные');
if a=1 then
writeln(a,' год');
if (a>1) and (a<5) then
writeln(a,' года');
if((a mod 10 = 1) and (a div 10 <> 0 or 11 )) then writeln(a,' год');
if (a>=5) and (a mod 10 <> 2 or 3 or 4)and (a div 10 <> 10) then
writeln(a,' лет');
if (a<=5) and (a mod 10 = 2 or 3 or 4)and (a div 10 = 10) then writeln(a,' года ');
if(a>104) and (a<110)then writeln(a,' лет');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Чебурек стоит а рублей и b копеек. голодный студент покупает n штук. пользователь вводит a, b и n. программа выводит, сколько рублей и копеек придётся заплатить за все чебуреки.например, для a=20, b=55 и n=2 получим 41 рубль и 10 копеек.нужно составить программу в паскале.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

inna-zub
aidapiltoyan43
mariia39
ИвановнаВладимир1832
Anna389
achernakov
igraparkGP51
knigi21212
Сергей_Евгеньевич1255
Константин Андрей
Yelizaveta555
yyyaga
ynikolaev2657
shuramuji
mstrshulz
▲