inainainainaina0073
?>

Написать программу на c++ которая выводит пирамиду из чисел. с клавиатуры водится число и до этого числа строится пирамида. вот как должно выглядеть(пример)

Информатика

Ответы

galinasemyan689

#include <iostream>

using namespace std;

int main()

{

 int n, i, j;

 string s, c;

 cout << "N = ";

 cin >> n;

 s = string(n, ' ');

 for (i = 1; i <= n; i++) {

   cout << "\n" << s;

   s.erase(s.size() - 1);

   for (j = 1; j <= i; j++) {

     if (n <= 9)

       c = " ";

     else

       c = i <= 9 ? "  " : " ";

     cout << c << i;

   }

 }

}

Chausmonk4

#include <iostream>

using namespace std;

int main()

{

   int mas[20] = {};

   int even = 0;

   int odd = 0;

   for (int i = 0; i < 20; i++)

   {

       cin >> mas[i];

   }

   for (int i = 0; i < 20; i++)

   {

       if (mas[i] % 2 == 0)

       {

           even++;

       }

       else

       {

           odd++;

       }

   }

   if (even > odd)

   {

       cout << "Чётных больше.";

   }

   else if (odd > even)

   {

       cout << "Нечётных больше.";

   }

   else

   {

       cout << "Равное количество.";

   }

}

Объяснение:

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()

{

   int mas[20] = {}; // Создание целочисленного массива размерностью 20, заполненного нулями

   int even = 0; // Создание целочисленной переменной, хранящей количество четных элементов

   int odd = 0; // Создание целочисленной переменной, хранящей количество нечетных элементов

   for (int i = 0; i < 20; i++) // Идём по массиву

   {

       cin >> mas[i]; // Вводим элементы массива с клавиатуры

   }

   for (int i = 0; i < 20; i++) // Идём по массиву

   {

       if (mas[i] % 2 == 0) // Если остаток от деления значения массива mas с индексом i на 2 = 0

       {

           even++; // +1 к четному

       }

       else // Иначе

       {

           odd++; // +1 к нечетному

       }

   }

   if (even > odd) // Если значение переменной even > значения переменной odd

   {

       cout << "Чётных больше."; // Выводим ответ

   }

   else if (odd > even) // Если значение переменной odd > значения переменной even

   {

       cout << "Нечётных больше."; // Выводим ответ

   }

   else // Иначе

   {

       cout << "Равное количество."; // Выводим ответ

   }

}

dzo-dzo

3)не (X и Y) или Z

Объяснение:

1) не (X и Y) и Z

Поскольку тут перед Z стоит операция И, то при Z = 0 всегда будет F = 0, поэтому такая функция исключается.

2) не (X или не Y) или Z

Поскольку тут перед Z стоит операция ИЛИ, то при Z = 1 будет F = 1. Проверим комбинации, где Z = 0.

Для X=0, Y=0 получаем

F = не (0 или не 0)

F = не (0 или 1)

F = не (1)

F = 0

Но в первой строке таблицы стоит 1, поэтому такая функция исключается.

3) не (X и Y) или Z

Здесь по Z рассуждения, как в 2).

Для X=0, Y=0 получаем

F = не (0 и 0)

F = не (0)

F = 1 - первая строка проверку.

Для X=0, Y=1 получаем

F = не (1 и 0)

F = не (0)

F = 1 - последняя строка проверку.

Функция подходит.

4) (X или Y) и Z

Рассуждения, как в случае 1), функция не подходит.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на c++ которая выводит пирамиду из чисел. с клавиатуры водится число и до этого числа строится пирамида. вот как должно выглядеть(пример)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Шитенков
Tanyamitia
Тамара_Григорьевна897
AlekseiBunina1895
kim-1971
klkkan
fedoseevalyubov
guzelda19904850
lezzzzka5510
tagirova1
Vkois56
metelkin7338
Tipan77
buslavgroupe
Павел_Перелыгин