КараханянКусков
?>

Написать программу, которая проверяет, делится ли на три целое число, введенное с клавиатуры.

Информатика

Ответы

Bulanova

program Div3;

var

 n: Integer;

begin

 Write ('Введите число: ');

 ReadLn (n);

 if n mod 3 = 0 then

   WriteLn (n, ' делится на 3')

 else

   WriteLn (n, ' не делится на 3');

 ReadLn;

end.

coleslow12

Если сумма цифр какого то числа делится на три, тогда это число делится на три

LesnovaVeronika1830
Windows  – без обновления операционной системы, вы и не почувствуете всех обновлений. мы рекомендуем  установить windows 8, так как она выполнена по всем современным меркам.монитор  – это первое на что мы обращаем внимание, сидя за компьютером, и чем он будет больше и красивее, тем больше положительных эмоций вы получите от обновления пк. рекомендуем для этого прочесть статью: «как выбрать монитор для компьютера». в подключении монитора думаем, что вопросов не возникнет.клавиатуру и мышь  – какое же внешнее обновление компьютера без замены  мышкиили  клавиатуры? ! обязательно выберите себе новые манипуляторы! коробку системного блока  – даже если у вас нет денег (или желания) обновлять все комплектующие компьютера (например, и этими вы довольно), то просто обновите коробку системного блока на современную. в этом случае все вокруг подумают, что вы обновили своё пк полностью! если нет навыков сбора компьютера – доверьте это дело профессионалам, таким как на masterservis24.ru! акустика  – последним штрихом в создании нового образа компьютера будет новое звучание и новый вид колонок для компьютера, чтобы вы не только видели обновленный компьютер, но и слышали его. кстати колонки можно просто заменить  новыми и хорошими наушниками для компьютера. если вас устраивает внешний вид пк, а больше интересует скорость его работы, то вам нужно выполнить обновление следующих деталей: процессор  – главная деталь всего компьютера, так как именно от мощности этого устройства зависит быстрота работы всей системы. помните, что  выбирать процессор для компьютера нужно правильно  (о чём мы уже писали ранее).материнская плата  – её нужно менять по нескольким причинам: во-первых, каждый из процессоров подходит только к определенным моделям «материнки». во-вторых, вам на материнской плате может не хватать слотов для дополнительного озу или второй видеокарты. о том,  как выбрать материнскую плату  мы писали ранее. устанавливать её самостоятельно не советуем, лучше попросить о .оперативное запоминающее устройство (озу)  – его также следует обновлять, однако если не хватает денег, то лучше выбрать более мощный процессор, чем много озу, ведь память всегда можно добавить самостоятельно и даже не вызывая мастера.жесткий диск  – скорости в работе компьютера он вряд ли прибавит (если только это не ssd диск), зато у вас появиться масса свободного места для разных файлов. перед тем, как купить жесткий диск, рекомендуем прочесть статью  как его выбрать, а также  как правильно устанавливать жесткий диск.видеокарта  – обновлять её нужно только в том случае, если она вышла из строя (шумит, например) или вы хотите играть в новые компьютерные игры, которые требуют более нового «железа».блок питания  – о том,  как выбрать блок питания  мы писали совсем недавно, и его замена будет для вас больше вынужденной, так как новые комплектующие устройства всегда более требовательны к энергии. новый блок питания не даст сгореть компьютеру и обеспечит его стабильную работу.
homeo85

1) для перевода из 10-й в двоичную 2-ую систему счисления нужно число в десятичной системе разделить на 2 и записать остаток , затем тоже самое сделать с целой часть и повторять пока не останется только 1 или 0. конечное числом будут остатки записанные в обратном порядке.

1450/ 2 = 725 остаток 0

725 / 2 = 362 остаток 1

362 / 2 = 181 остаток 0

181 / 2 = 90 остаток 1

90 / 2 = 45 остаток 0

45/ 2 = 22 остаток1

22/2 = 11 остаток 0

11/ 2 = 5 остаток 1

5 / 2 = 2 остаток 1

2 / 2 = 1 остаток 0

1 / 2 = 0 остаток 1

 

результат: 10110101010

 

в 2-х байтовой ячеке всего 16 разрядов, а в наше числе 11 , значит спереди нужно дописать 5 нулей и получим нужное представление

0000010110101010

 

2)

для перевода в 16 систему нужно сначало перевести в 2-ю систему счисления, потом записать обратный код, почитать дополнительный и тогда перевести в 16-ю

вот 1450 в 2-й системе

0000010110101010

обратный код это код в котором все 0 заменены на 1, а 1 на 0

1111101001010101

чтобы получит дополнительный код нужно прибавить 1

1111101001010110

теперь смотрим по 4 разряда и заменяем 1 символом в 16 системе счисления

1111 = f

1010 = a

0101 = 5

0110 = 6

искомое число fa56

3)

  для перевода из 16 в 2 систему счисления нужно каждую цифру числа умножит на 16 в степень равным номеру цифры(справа на лево, отсчет с 0)

f67d(в 16 системе счисления) = 15 * 16 ^3 + 6 * 16 ^2 + 7 * 16^1 + 13 * 16 ^0 = 61440 + 1536 + 112 + 13 = 63101(в 10 системе счисления)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая проверяет, делится ли на три целое число, введенное с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

serg1976g
zazaza74
denis302007
A2017
samuilik-v
mospaskrasnogorbukh
Дементьева-Артем1315
adman7
Sacharov84
Vova220
rstas
Есартия52
Окунева-Мотова
margo929
elenachuxina804