Объяснение:
1) Организуем ввод данных
3) Создадим функцию, которая вычисляет сумму чётных элементов
4) Создадим функцию, которая вычисляет сумму нечётных элементов
5) Выведем разность первой и второй функции
Пример реализации функций (для чётных, для нечётных аналогично)
1) Если А чётно, то начнём с неё, иначе с А+1 элемента
2) Если В чётно, то закончим им, иначе В-1
3) Количество элементов N - ((Верхняя граница - нижняя граница) целочисленно разделить на 2) + 1
4) Прогрессия (Нижняя граница + Верхняя граница)*N/2
5) Присваиваем значение 4 функции
6) Аналогично организуем для нечётных элементов
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая вычисляет разность суммы чётных и суммы нечётных чисел от a до b с суммы арифметической прогрессии. ввод: 3 6 вывод: 2 ввод: 3 7 вывод; -5
program ChetNechet;
var
A, B, chet, nechet, otvet, i: Integer;
begin
Write ('Введите А, В: ');
ReadLn (A, B);
chet := 0;
nechet := 0;
for i := A to B do begin
if i mod 2 = 0 then
chet := chet + i;
else
nechet := nechet + i;
end;
otvet := chet - nechet;
WriteLn ('Сумма четных: ', chet);
WriteLn ('Сумма нечетных: ', nechet);
WriteLn ('ответ: ', otvet);
ReadLn;
end.