Burov1446
?>

Решить на паскале.с клавиатуры вводятся координаты точки на плоскости (x, y – действительные числа. написать программу, определяющую принадлежность точки заштрихованной области, включая ее границы.

Информатика

Ответы

ivan-levermor

program Test;

var

 x, y: Double;

begin

 WriteLn ('Введите координаты x и y: ');

 ReadLn (x, y);

 if (x >= 0) and (x <= Pi) and (y >= 0) and (y <= 0.5) and (y <= Sin (x)) then

   WriteLn ('Принадлежит')

 else

   WriteLn ('Не принадлежит');

 ReadLn;

end.

Объяснение:

Первые 4 условия проверяют прямоугольник от (0, 0) до (п, 0,5)

последнее условие проверяет левый и правый край этого прямоугольника на принадлежность к графику Sin (x)

baron

Цель:Развить навыки обработки строковых данных. Уметь использовать различные методы обработки строк. Получить навыки в организации работы со строковыми переменными: удалением, вставкой, копированием, заменой одной строки на другую и т.д.

Оборудование и материалы:Методическое пособие, ПЭВМ, ручка, карандаш, линейка, ластик, шаблон А4.

Ход работы

Методические рекомендации.

Необходимая информация содержится в лекциях № 19-22.

Решение задач представить в следующем порядке: постановка задачи, построение математической модели, блок-схемы, программный код, тестирование.

Задание для лабораторной работы выбрать согласно варианту по приведённой таблице. Вариант определяется порядковым номером в журнале группы.

Для работы с символьной информацией используют новый тип данных - строковый, именуемый ключевым словом string (или просто строка). Этот тип данных во многом похож на одномерный массив символов (Array[0..N] of char), но длина строки (максимальное количество символов N ограничивается числом 255). Значение N определяется при объявлении типа string (N) и может быть любой константой порядкового типа, но не больше 255. Значение N при объявлении типа string можно не указывать: в этом случае длина строки принимается равной 255 символам.

Строка трактуется как цепочка символов и к любому символу в строке можно обратиться по адресу (индексу), подобно одномерным массивам типа Array[0..N] of char. Самый первый байт в строке, имеющий адрес 0 (ноль), содержит код, равный числу символов в строке (длине строки).

Например, дана строка, имеющая следующее описание:

Var St: string;

Тогда длину строки St можно определить как значение функции

maria

ну, для начала, стоит упомянуть, что с ее можно печатать машины! создатели последнего фильма о бонде, скайфол, наняли компанию voxeljet, которая специализируется на 3d-печати, для создания трех моделей престижной машины астон мартин db5 масштабом 1: 3 для съемок аварий. но не расстраивайтесь, одна из них уцелела и позднее была продана на аукционе кристис почти за 100 000 фунтов стерлингов.                                                                                            корпуса для мобильных устройств                                                меньше размером, но не менее роскошная, первая в мире модель корпуса nokia lumia 820 была отпечатана мастерами 3d-печати, в компании makerbot. меньше чем за день после того, как были переданы в работу спецификации, специалисты компании при 3d-магии создали эту модель. протезирование индустрия медицинского оборудования - один из крупнейших рынков в мире 3d-печати. нужен бедренный сустав? распечатаем! рынок протезирования просто влюблен в 3d-технологию. специалисты бельгийской компании biomedics недавно имплантировали распечатанную на 3d-принтере титановую челюсть 83-летней пациентке. и это только начало! детали машин подполковник авиации энди грин намерен побить рекорд скорости на суше, пилотируя сверхзвуковой автомобиль развивать скорость свыше 1600 км/час - автомобиль с внутренностями, выполненными на 3d-принтере. при системы автоматизированного проектирования и глиняного слепка руки грина, титановое рулевое колесо было отпечатано максимально удобным для рук бесстрашного гонщика. на старт, медицина к нашему удивлению мы узнали, что еще 3d-принтеры можно использовать в сочетании со сканами системы автоматизированного проектирования для распечатывания клона опухоли перед операцией, с тем чтобы хирурги точно знали, с чем именно им придется иметь дело. удобно! предметы ученые из уорикского университета сообщили, что электронная схема может быть неотъемлемой частью 3d-напечатанных предметов, и чтобы доказать это, они изобрели материал, который называли carbomorph, а затем использовали его для создания компьютерного игрового устройства и кружки, которая знает, когда она наполнена. космос наса и исследователи вашингтонского государственного университета работают над 3d-печатью лунной пылью. с этой технологией мы могли бы в будущем рассматривать возможность изготовления лунной базы непосредственно на месте, целиком из материалов доступных на луне. в то же время космонавты могли бы использовать эту технологию для починки и замены сломанного оборудования. хьюстон, есть идея! почта полагаете, что посылки идут слишком медленно? файлообменник pirate bay недавно открыл новый раздел на своем сайте под названием "physibles", для того, что они описывают как "объекты данных, которые могут стать осязаемыми". другими словами, достаточно загрузить свои 3d-чертежи, и любой, кто получит этот файл сможет распечатать реальный предмет. вот это называется делиться! компьютерные герои но будьте осторожны: несколько любителей компьютерных игр нажили неприятности с законом когда стали использовать свои принтеры для воспроизводства фигурок из warhammer 40000. games workshop - создатели warhammer - быстро вмешались в их деятельность, волнуясь о своих правах на патенты. похоже, что следующей битвой на поле авторских прав на цифровые изделия будет борьба закак видите, 3d-печать уже преподносит нам не мало сюрпризов, но, очевидно, самое интересное еще впереди. а если бы вы были ограничены лишь вашим воображением, что бы вы напечатали в первую очередь?

программное обеспечение компьютера делится на:

- системное по;

- прикладное по;

- системы программирования.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на паскале.с клавиатуры вводятся координаты точки на плоскости (x, y – действительные числа. написать программу, определяющую принадлежность точки заштрихованной области, включая ее границы.
Ваше имя (никнейм)*
Email*
Комментарий*