eremenkou
?>

Напишите программу на pascal(и желательно блок-схему) дан массив целочисленных матриц. вывести матрицы, имею- щие наибольшее число нулевых строк.

Информатика

Ответы

tofilev
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var
  a: array of integer;
  i, n, m: integer;
function simple(x:integer): boolean;
var
  i: integer;
begin
  Simple := false;
  if x < 2 then exit;
  if x mod 2 = 0 then exit;
  i := 3;
  while i <= sqrt(x) do
  begin
    if x mod i = 0 then exit;
    i +=2;
  end;
  Simple := true;
end;

begin
  write('Количество элементов массива :');readln(m);
  SetLength(a, m);
  while n <= m - 1 do
  begin
    if simple(i) then begin
      a[n] := i;
      n +=1;
    end;
    i +=1;
  end;
a.println;  
end.

Тестовое решение:
Количество элементов массива :25
2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97
Низамов
Под угрозой информационной безопасности принято понимать потенциально возможные действия, явления или процессы оказать нежелательное воздействие на систему или на хранящуюся в ней информацию.Такие угрозы, воздействуя на ресурсы, могут привести к искажению данных, копированию, несанкционированному распространению, ограничению или блокированию к ним доступа. В настоящее время известно достаточно  большое количество угроз, которые классифицируют по различным признакам.По природе возникновения различают естественные и искусственные угрозы. К первой группе относятся те, что вызваны воздействием на компьютерную систему объективных физических процессов или стихийных природных явлений. Вторая группа – те угрозы, которые обусловлены деятельностью человека.По степени преднамеренности проявления, угрозы разделяют на случайные ипреднамеренные.Также есть разделение в зависимости от их непосредственного источника, в качестве которого может выступать природная среда (например, стихийные бедствия), человек (разглашение конфиденциальных данных), программно-аппаратные средства: санкционированные (ошибка в работе операционной системы) и несанкционированные (заражение системы вирусами).Источник угроз может иметь разное положение. В зависимости от этого фактора также выделяют три группы:- Угрозы, источник которых находятся вне контролируемой группы компьютерной системы (пример – перехват данных, передаваемых по каналам связи)- Угрозы, источник которых – в пределах контролируемой зоны системы (это может быть хищение носителей информации)- Угрозы, находящиеся непосредственно в самой системе (например, некорректное использование ресурсов).Угрозы по-разному воздействовать на компьютерную  систему.  Это могут быть пассивные воздействия, реализация которых не влечет за собой изменение структуры данных (например, копирование). Активные угрозы — это такие, которые, наоборот, меняют структуру и содержание компьютерной системы (внедрение специальных программ).В соответствии с разделением угроз по  этапам доступа пользователей или программ к ресурсам системы существуют  такие опасности, которые проявляются на этапе доступа к компьютеру и обнаружимые после разрешения доступа (несанкционированное использование ресурсов).Классификация по месту расположения в системе подразумевает деление на три группы: угрозы доступа к информации, находящейся на  внешних запоминающих устройствах, в оперативной памяти и к той, что циркулирует в линиях связи.ОТВЕТ ВЗЯТ ИЗ ИНТЕРНЕТА!!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на pascal(и желательно блок-схему) дан массив целочисленных матриц. вывести матрицы, имею- щие наибольшее число нулевых строк.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vladimir686
zhannasokortova
IPMelnikovR146
kabinet17
Mariya694
ldstroy
zeltos384
dmtr77
Египтян2004
Евгеньевич Балиловна1398
aureole6452
uisfbu7777733
Измайлова-Алексей
Tatyanaaarzieva72
Ольга Сергей1822