var
x, y, r: real;
begin
read(x, y, R);
if (x * x + y * y <= R * R) or
(y <= 0) and (y >= -2 * x) and (y >= 2 * (x - R)) then
write('попадает')
else
write('не попадает');
end.
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, определяющую, попадает ли точка с заданными координатами x и y в закрашенную область (использовать формулы уравнения прямой, проходящей через две точки, уравнения окружности, уравнения прямых, параллельных осям координат результат работы программы вывести в виде текстового сообщения. (параметры r, r1, r2, a, b, с вводятся с клавиатуры.) - если имеются
отправь нарушение ошипся я не знаю