yuip2008
?>

Дайте развернутые ответы на вопросы: 1. как блок-схемой и на алгоритмическом языке представляется команда цикла с предусловием? пример.2. как программируется цикл с предусловием на алгоритмическом языке и как на языке паскаль? 3. почему алгоритм вычисления n! должен быть цикличным? постройте данный алгоритм.4. составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа n.

Информатика

Ответы

lanac3po
1)program fagasg;
var x1,y1,r: real;
begin
Writeln('Введите х1');
readln(x1);
Writeln('Введите у1');
readln(y1);
r:=sqrt(x1*x1+y1*y1);
Writeln('Расстояние от х1 до у1=',r);
end.
2)Program fsgasghfd;
var c,s: real;   
a,b: integer;
begin
Writeln('Введите первое целое число');
readln(a);
Writeln('Введите второе целое число');
readln(b);
Writeln('Введите дробное число');
readln(c);
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then 
s:=a+b+c
else writeln('Знаки разные');
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then Writeln('Сумма чисел:',s);
end.
3)Program wrqrwqr;
var A: Array[1..100] of integer;   
B: Array[1..100] of integer;   
C: Array[1..100] of integer;   
s,i,h,g: integer;
begin
h:=0;
g:=0;
Writeln('введите размерность массива');
readln(s);
Writeln('Вводится первый массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(A[i]); 
end;
Writeln('Вводится второй массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(B[i]); 
end;
For i:=1 to s do  begin   
If A[i]>B[i] then C[i]:=A[i]     
else C[i]:=B[i];   
If C[i] mod 2=1 then h:=h+1;   
If C[i] mod 2=0 then g:=g+1; 
end; 
Writeln('Количество нечётных элементов в массиве:',h); 
Writeln('Количество чётных элементов в массиве:',g);
end.
Anton661
1)program fagasg;
var x1,y1,r: real;
begin
Writeln('Введите х1');
readln(x1);
Writeln('Введите у1');
readln(y1);
r:=sqrt(x1*x1+y1*y1);
Writeln('Расстояние от х1 до у1=',r);
end.
2)Program fsgasghfd;
var c,s: real;   
a,b: integer;
begin
Writeln('Введите первое целое число');
readln(a);
Writeln('Введите второе целое число');
readln(b);
Writeln('Введите дробное число');
readln(c);
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then 
s:=a+b+c
else writeln('Знаки разные');
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then Writeln('Сумма чисел:',s);
end.
3)Program wrqrwqr;
var A: Array[1..100] of integer;   
B: Array[1..100] of integer;   
C: Array[1..100] of integer;   
s,i,h,g: integer;
begin
h:=0;
g:=0;
Writeln('введите размерность массива');
readln(s);
Writeln('Вводится первый массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(A[i]); 
end;
Writeln('Вводится второй массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(B[i]); 
end;
For i:=1 to s do  begin   
If A[i]>B[i] then C[i]:=A[i]     
else C[i]:=B[i];   
If C[i] mod 2=1 then h:=h+1;   
If C[i] mod 2=0 then g:=g+1; 
end; 
Writeln('Количество нечётных элементов в массиве:',h); 
Writeln('Количество чётных элементов в массиве:',g);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дайте развернутые ответы на вопросы: 1. как блок-схемой и на алгоритмическом языке представляется команда цикла с предусловием? пример.2. как программируется цикл с предусловием на алгоритмическом языке и как на языке паскаль? 3. почему алгоритм вычисления n! должен быть цикличным? постройте данный алгоритм.4. составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа n.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gorbunova188
Виктор Попова
Платон Демцун
Владимирович_Слабый
markitandl
ver2bit29
Dmitrii sergei463
kattarina71
andreevaalisa
olgamalochinska
fouettearoma
arturo95
mira15963256
Nikishina
strager338