Платон Демцун
?>

Составить алгоритм сложения двух целых чисел A и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной Z. По данному алгоритму написать программу в Паскале. Алгоритм 1. алг сложение цел A, Q, Z нач ввод A ввод Q Z:=A+Q вывод Z кон 2. алг сложение цел A, Q, Z нач ввод A ввод Q Z=A+Q вывод Z кон 3. алг сложение цел A, Q, Z нач ввод A ввод Z Q:=A+Z вывод Z кон Программа в Паскале 1. program summa; var A, Q, Z:integer; begin readln(A); readln(Q); Z:=A+Q; writeln(A); end. 2. program summa; var A, Q, Z:integer; begin readln(A); readln(Q); Z:=A+Q; writeln(Z); end. 3. program summa; var A, Q, Z:integer; begin readln(A); readln(Q); Z:=A+Q; writeln(Z);

Информатика

Ответы

notka19746

ответ:в первом 2,во втором 1

Объяснение:

yurazharov

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

   srand ( time(NULL) );

   int arr[10],i,k=0;

   //Заполняешь массив

   for (i=0;i<sizeof(arr)/sizeof(int);i++)

   {

       arr[i] = 1+rand()%10;

   }

   //Перебираешь массив

   cout<<"Массив :";

   for (int i=0; i<sizeof(arr)/sizeof(int);i++)

   {

       cout<<" "<<arr[i];

       if (arr[i] % 2 == 0)

       {

           k++;

       }

   }

   cout<<endl<<"Четных :"<<k;

   return 0;

}

Объяснение:

много на самом деле. Например самый банальный. Перебираешь массив и проверяешь, если текущий элемент при делении на 2 дает в остатке 0 - значит четное. Значит прибавляешь счетчик (например, переменную a++). Иначе ничего не делаешь. В конце выводишь результат счетчика (a)

NataliaBerezovskaya33

Объяснение:

Алгоритм решения данной задачи можно описать так:

За у пользователя количество шагов сдвига и направление. Условиться, что если вводится отрицательное целое, то сдвиг выполняется влево на указанное абсолютное значение, если вводится положительное число, то сдвиг вправо.

Заполнить исходный массив и вывести его на экран.

Выполнять внешний цикл столько раз, сколько шагов было указано.

Если было введено отрицательное число, то выполнить цикл от первого элемента до предпоследнего, перезаписав в нем значение каждой очередной ячейки на значение последующей. Записать в последнюю ячейку 0.

Иначе, выполнить цикл от последнего элемента до второго, записывая в каждую текущую ячейку значение предыдущей. В первую ячейку записать 0.

Вывести на экран текущий массив.

Сдвиг Влево

-4

111 222 333 444 555 666 777 888 999

222 333 444 555 666 777 888 999   0

333 444 555 666 777 888 999   0   0

444 555 666 777 888 999   0   0   0

555 666 777 888 999   0   0   0   0

Сдвиг в Право

5

111 222 333 444 555 666 777 888 999

  0 111 222 333 444 555 666 777 888

  0   0 111 222 333 444 555 666 777

  0   0   0 111 222 333 444 555 666

  0   0   0   0 111 222 333 444 555

  0   0   0   0   0 111 222 333 444

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить алгоритм сложения двух целых чисел A и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной Z. По данному алгоритму написать программу в Паскале. Алгоритм 1. алг сложение цел A, Q, Z нач ввод A ввод Q Z:=A+Q вывод Z кон 2. алг сложение цел A, Q, Z нач ввод A ввод Q Z=A+Q вывод Z кон 3. алг сложение цел A, Q, Z нач ввод A ввод Z Q:=A+Z вывод Z кон Программа в Паскале 1. program summa; var A, Q, Z:integer; begin readln(A); readln(Q); Z:=A+Q; writeln(A); end. 2. program summa; var A, Q, Z:integer; begin readln(A); readln(Q); Z:=A+Q; writeln(Z); end. 3. program summa; var A, Q, Z:integer; begin readln(A); readln(Q); Z:=A+Q; writeln(Z);
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

potapenkoon72
smalltalkcoffee5
generallor3
Valerevna Tuzova
boldyrevanastia22
Жуков219
Анатольевич-Митюшин
yuip2008
milaudina
Виктория1690
Kochereva-Sergei
people33
solonataly5
ilyanedelev
ilyushin-e