#1:
const
Count = 3; // количество проверяемых чисел
var
m : array [1..Count] of Integer;
i, e, c: Integer;
begin
Writeln('Введите числа:');
for i := 1 to Count do
begin
Write(i ,': '); Readln( m[i] );
end;
for i := 1 to Count do
for e := 1 to Count do
if m[i] < m[e] then
begin
c := m[i];
m[i] := m[e];
m[e] := c;
end;
for i := 1 to Count do
Write(m[i], ' ');
Readln;
end.
#2:
var
a, b, c, x, y: Integer;
begin
Writeln('Введите рёбра кирпича:');
Write('a: '); Readln( a );
Write('b: '); Readln( b );
Write('c: '); Readln( c );
Writeln('Введите стороны отверстия:');
Write('x: '); Readln( x );
Write('y: '); Readln( y );
x := x*y;
if (a*b <= x) or (a*c <= x) or (b*c <= x) then
Write('Пройдёт.')
else
Write('не пройдёт.');
Readln;
end.
План характеристики химического элемента
по его положению в периодической таблице элементов
1. Название химического элемента. Химический знак этого элемента.
2. Положение в периодической таблице (порядковый номер, номер периода (малый, большой), номер группы.
3. Металл или неметалл.
4. Высшая валентность в кислородных соединениях, формулы высшего оксида, соответствующего гидроксида или кислоты, характер их свойств.
5. Валентность в водородном соединении, формула летучего водородного соединения (для неметаллов).
В ответе ставим только номера пунктов плана.
Поделитесь своими знаниями, ответьте на вопрос:
30 составить программу нахождения произведения значений элементов массива состоящего из 10 целых чисел. значение элементов массива заданы с формулы a[i]: = i*i-1
0
На PascalABC.NET:
begin
ArrGen(10, i -> i * i - 1, 1).Product.Println;
end.
Писать программу по хорошему смысла нет. При i =1 получаем a[1] = 0 и все дальнейшие умножения от 0 не будут отличаться.