peresvetoff100015
?>

Написать программу языком с++ 42 задано целочисленный массив (матрица) а размерности 5х5. массив а иницализуваты элементами в тексте программы при его описании (заполнить произвольно - 5 строк по 5 чисел в массиве а найти указанные в варианте величины и вывести результат в виде сообщения на консоль, выведя предварительно массив в виде таблицы. образовать новый массив в, согласно указаниям соответствующего варианта, образованный массив вывести на консоль. : в массиве а найти разницу средних значений отдельно взятых положительных и отрицательное элементов. массив в образовать из массива а, заменив в нем все элементы меньше -5 на противоположные. за правильную все и выберу лучший ответ! заранее ! )

Информатика

Ответы

belka1976
//1
var A, B, i: integer;
begin
  write('Введите A и B: '); readln(A, B);
  for i := A to B do
    if ((i mod 3 = 0) and (i mod 10 = 3)) then writeln(i);
end.

//2
var
  A, B, i, k: integer;
begin
  write('Введите A и B: '); readln(A, B);
  for i := A to B do
    if ((i > 99) and (i < 1000)) and ((i mod 10 = 9) and (i mod 100 <> 99)) then
    begin
      writeln(i);
      k := k + 1;
    end;
    if k = 0 then writeln('Таких чисел нет.');
end.

//3
var sum, i, n: integer;
begin
  write('Введите количество предметов: '); readln(n);
  for i := 1 to n do
  begin
    readln(n);
    sum := sum + n;
  end;
  writeln('Общая масса = ', sum);
end.

//3 с другим циклом
var sum, n: integer;
begin
  writeln('Введите 0 для завершения ввода.');
  repeat
    readln(n);
    sum := sum + n;
  until n = 0;
  writeln('Общая масса = ', sum);
end.
marimelons795
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var (a,b):=ReadInteger2('Границы интервала [A,B]:');
  for var n:=a to b do
    if (Abs(n mod 10)=3) and (n mod 3=0) then Print(n)
end.

Пример
Границы интервала [A,B]: -50 142
-33 -3 3 33 63 93 123

№2

begin
  var (a,b):=ReadInteger2('Границы интервала [A,B]:');
  var k:=0;
  for var n:=a to b do begin
    var m:=Abs(n);
    if (m mod 10=9) and (m mod 100<>99) and (m>=100)
        and (m<=999) then begin Print(n); k+=1 end
    end;
  if k=0 then Writeln('Таких чисел нет') 
end.

Примеры
Границы интервала [A,B]: -200 160
-189 -179 -169 -159 -149 -139 -129 -119 -109 109 119 129 139 149 159

Границы интервала [A,B]: 52 101
Таких чисел нет

№3

begin
  var n:=ReadInteger('Введите количество предметов:');
  var m:=0.0;
  for var i:=1 to n do begin
    Write('Маcса предмета № ',i,': '); m+=ReadReal;
    end;
  Writeln('Масса груза равна ',m)
end.

Пример
Введите количество предметов: 5
Маcса предмета № 1: 24.62
Маcса предмета № 2: 8.1
Маcса предмета № 3: 132
Маcса предмета № 4: 24.5
Маcса предмета № 5: 52.7
Масса груза равна 241.92

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу языком с++ 42 задано целочисленный массив (матрица) а размерности 5х5. массив а иницализуваты элементами в тексте программы при его описании (заполнить произвольно - 5 строк по 5 чисел в массиве а найти указанные в варианте величины и вывести результат в виде сообщения на консоль, выведя предварительно массив в виде таблицы. образовать новый массив в, согласно указаниям соответствующего варианта, образованный массив вывести на консоль. : в массиве а найти разницу средних значений отдельно взятых положительных и отрицательное элементов. массив в образовать из массива а, заменив в нем все элементы меньше -5 на противоположные. за правильную все и выберу лучший ответ! заранее ! )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bronco-s
reinish23
alisabutusova
Хрулёва
gernovoy
Yuliya_Viktoriya316
mishink535
сергеевич1958
ekaterinaorl1998
Yurevich1291
Aleksandrovich-Mayatskikh
samuilik-v
groomingprofi56
hello
Getmantsev417