ibombenkova
?>

Где х= там фигурная скобка. составить и записать алгоритм следующей составить программу вычисления функции. 5sinx? если x меньше или равно a x=4 cosx, если a меньше х меньше b 3tgx.если х больше или равно b

Информатика

Ответы

fetisov68av
Решение №1 (без массивов)

var a,n,i,j,s:integer;
begin
  writeln('Введите количество цифр в числе');
  readln(n);
  for i:=1 to n do begin
    writeln('Введите ',i,' цифру из ',n);
    readln(a);
    for j:=1 to n-i do a:=a*10;
    s:=s+a;
  end;
  writeln('Натуральное число: ',s);
end.

Тестовое решение

Введите количество цифр в числе
5
Введите 1 цифру из 5
9
Введите 2 цифру из 5
2
Введите 3 цифру из 5
7
Введите 4 цифру из 5
3
Введите 5 цифру из 5
1
Натуральное число: 92731

Решение №2 Если очень надо использовать массив (хотя на мой взгляд совсем не нужно)

//PascalABC.NET (версия 3.1, сборка 1198)
var a,n,i,j,s:integer;
mas:array[1..10]of integer;
begin
  writeln('Введите количество цифр в числе');
  readln(n);
  for i:=1 to n do begin
    writeln('Введите ',i,' цифру из ',n);
    readln(mas[i]);
    a:=mas[i];  
    for j:=1 to n-i do a:=a*10;
    s:=s+a;
  end;
  writeln('Натуральное число: ',s);
end.

Тестовое решение

Введите количество цифр в числе
5
Введите 1 цифру из 5
5
Введите 2 цифру из 5
4
Введите 3 цифру из 5
3
Введите 4 цифру из 5
2
Введите 5 цифру из 5
2
Натуральное число: 54322
Yevgenevna
1)Растровый графический файл содержит черно-белое изображение (без градаций серого) размером 100 на 100 точек. Какой объем памяти требуется для храненияэто файла?
Решение: 100*100=10000 точек
2 градации цвета (черный, белый)=1бит
Следовательно: 10000бит
2) Рисунок построен с использованием палитры 256 цветов на экране монитора с графическим разрешением 1024 на 768. Рассчитать объем памяти необходимый для хранения этого рисунка?
Решение: 256=2^8 степени
1024*768=786432бит / 8 = 98304 бит = 12288байт = 12Кб

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Где х= там фигурная скобка. составить и записать алгоритм следующей составить программу вычисления функции. 5sinx? если x меньше или равно a x=4 cosx, если a меньше х меньше b 3tgx.если х больше или равно b
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tinadarsi
irinanikulshina144
elenabarskova7145
leobashkurov1089
Mikuspavel2
info6
tanias
Екатерина
alislisa191
Андрееевич787
Lidburg
emartynova25
Fedorova_79166180822
seletan1
elena-ruzadom