lena260980
?>

Написать код в паскале в исходном текстовом файле записаны строки, содержащие текст на языке. требуется написать программу, которая для каждой строки исходного файла будет определять и выводить в результирующий файл букву, встречающуюся в этой строке чаще всего, и количество там таких букв. строчные и прописные буквы при этом считаются не различимыми. если искомых букв несколько, то программа должна выводить на экран первую из них по алфавиту. например, пусть в одной из строк исходного файла содержатся следующие символы: it is not a simple task. yes! в этом случае в результирующем файле должно быть: i 3

Информатика

Ответы

О. Карпов1691

===== PascalABC.NET =====

begin

 ReadLines('Sonet90.txt').

   Where(p -> p.Length > 0).

   Select(p -> p.ToUpper.MatchValues('[A-z]').

   GroupBy(p -> p).Select(p -> (p.Key, p.Count)).

   OrderBy(p -> -p[1]).ThenBy(p -> p[0]).First).

   Foreach(p -> Writeln(p[0], ' ', p[1]))

end.

В тестовом файле с именем Sonet90.txt (он прикреплен) находится оригинал известного сонета Шекспира №90. В нем есть и пробелы, и знаки препинания и даже пустая строка.

Then hate me when thou wilt; if ever, now;

Now, while the world is bent my deeds to cross,

Join with the spite of fortune, make me bow,

And do not drop in for an after-loss:

Ah, do not, when my heart hath 'scoped this sorrow,

Come in the rearward of a conquer'd woe;

Give not a windy night a rainy morrow,

To linger out a purposed overthrow.

If thou wilt leave me, do not leave me last,

When other petty griefs have done their spite

But in the onset come; so shall I taste

At first the very worst of fortune's might,

And other strains of woe, which now seem woe,

Compared with loss of thee will not seem so.

Во втором вложении показана работа программы.


Написать код в паскале в исходном текстовом файле записаны строки, содержащие текст на языке. требу
demakova1969

Объяснение:

#include <iostream>

#include <math.h>

using namespace std;

int main()

{

   int a, b, c, d;

   cout <<"vvedite a, b , c" << endl;

   cin >> a >> b >>c;

   if(a == 0.0)

   {

       cout << "a ravo 0!" << endl;

       return 0;

   }

   d = b*b - 4 * a * c;

   if(d < 0)

   {

       cout << "net kornei" << endl;

       return 0;

   }

   if(d == 0)

   {

       cout << "odin koren, x = " <<(-b)/2*a <<endl;

       return 0;

   }

   cout << "dva korna, x1 = " <<(-b + sqrt(d))/2*a << " x2 = " <<(-b - sqrt(d))/2*a << endl;

   return 0;

}


1. Составить блок схему алгоритма и написать программу на языке программирования С++, вычисления кор
xarfagr

1) 233₁₀ = 11101001₂

2) 870₁₀ = 1546₈

3) 287₁₀ = 11F₁₆

Объяснение:

1)

233 / 2 = 116 + остаток 1

116 / 2 = 58 + остаток 0

58 / 2 = 29 + остаток 0

29 / 2 = 14 + остаток 1

14 / 2 = 17 + остаток 0

7 / 2 = 3 + остаток 1

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

233₁₀ = 11101001₂

11101001₂ = 1 * 2⁷ + 1 * 2⁶ + 1 * 2⁵ + 0 * 2⁴ + 1 * 2³ + 0 * 2² + 0 * ¹2 + 1 * 2⁰ = 1 * 128 + 1 * 64 + 1 * 32 + 0 * 16 + 1 * 8 + 0 * 4 + 0 * 2 + 1 * 1 = 128 + 64 + 32 + 8 + 1 = 233₁₀

2)

870 / 8 = 108 + остаток 6

108 / 8 = 13 + остаток 4

13 / 8 = 1 + остаток 5

1 / 8 = 0 + остаток 1

записываем остатки снизу вверх

870₁₀ = 1546₈

1546₈ = 1 * 8³ + 5 * 8² + 4 * 8¹ + 6 * 8⁰ = 1 * 512 + 5 * 64 + 4 * 8 + 6 * 1 = 512 +320 + 32 + 6 = 870₁₀

3)

287 / 16 = 17 + остаток 15

17 / 16 = 1 + остаток 1

1 / 16 = 0 + остаток 1

записываем остатки снизу вверх

287₁₀ = 11F₁₆

11F₁₆ = 1 * 16² + 1 * 16¹ + F * 16⁰ = 1 * 256 + 1 * 16 + 15 * 1 = 256 + 16 + 15 = 287₁₀

В качестве цифр шестнадцатеричной системы счисления обычно используются цифры от 0 до 9 и латинские буквы от A до F.

A₁₆ = 10₁₀   B₁₆ = 11₁₀   C₁₆ = 12₁₀   D₁₆ = 13₁₀   E₁₆ = 14₁₀   F₁₆ = 15₁₀  

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать код в паскале в исходном текстовом файле записаны строки, содержащие текст на языке. требуется написать программу, которая для каждой строки исходного файла будет определять и выводить в результирующий файл букву, встречающуюся в этой строке чаще всего, и количество там таких букв. строчные и прописные буквы при этом считаются не различимыми. если искомых букв несколько, то программа должна выводить на экран первую из них по алфавиту. например, пусть в одной из строк исходного файла содержатся следующие символы: it is not a simple task. yes! в этом случае в результирующем файле должно быть: i 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aleks120498
markitandl
nairahay
aaltuxova16
Pautova1119
Aleksandr-Andrei
expozition
la-ronde737
Семеновна-Павел
mariia39
stepanova-natalie
petrova-kate3
dzo-dzo
helenya
len4ik1986