Reutskii884
?>

Разобраться с информатикой , составьте программу и забейте в окно вывода числа заранее )​

Информатика

Ответы

viktort889841

4 секунды Петр скачивал в одиночестве.Скорость закачки равнялась 24 Мбайт/сек.За это время он скачал 4 сек * 24 МБайт/сек = 96 Мбайт.Затем подключился Василий, и они стали 8 секунд вдвоем делить канал: 8 сек * 24/2 Мбайт/сек = 8*12 = 96 Мбайт.Таким образом, за 48 уже рассмотренных секунд Петр скачал 96 Мбайт + 96 Мбайт = 192 Мбайт. Ему осталось скачать 448 Мбайт - 192 Мбайт = 256 Мбайт.Оставшееся время канал был занят тремя людьми, следовательно пропускная на каждого стала равна 24/3 = 8 МБайт/сек.

И эти 256 Мбайт / 8 МБайт/сек = 32 сек.

Сложим все время: 4 сек + 8 сек + 32 сек = 44 сек

Объяснение:

вроде так

klodialeit36
Program t;
varn, x, i, s, k:integer;
a:array [0..20] of integer; {20 =это максимальное количество домов .Вместо 20 поставь любое  число}
begin
write('Введите количество домов на улице : ');
read(n);
for i:=1 to n do
begin
write('Введите количество жителей в ', i, ' -м доме : ');
read(a[i]);
end; 
for i:=1 to n do    
if i mod 2=0 then s:=a[i]+s; {Считаем жителей правых}        
        for i:=1 to n do
        if i mod 2=1 then k:=a[i]+k;{Считаем жителей левых} 
if s>k then write('Разница между домами ', k-s ); 
if s<k then write('Разница между домами ', s-k );
end.

Введите количество домов на улице : 3
Введите количество жителей в 1 -м доме : 3
Введите количество жителей в 2 -м доме : 1
Введите количество жителей в 3 -м доме : 4
Разница между домами -6

Писал на Версии 3.3
Скобки это комментарии,их можно убрать

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Разобраться с информатикой , составьте программу и забейте в окно вывода числа заранее )​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Овезова Игорь
Корягина
prostopo4ta29
pavlovm8316
artemka56rus
laktionova-natal
Maksim Lokhov
Aleksandrovich-Yurevna1421
dearmaria
vikola2008
Vorotko814
pastore
AkimovaI1608
dsnewline
Vladimirovna-Ignatenko1890