superniki87
?>

Исправить ошибки в программе у=e^-bt*sin(at+b) - sqrt|bt+a|; s=b*sin(at^2cos(at))-1 #include #include #include #define _use_math_defines //лаб.работа 4 студента гр.3108 //привалова любовь //вариант 18 int main() { printf("l.r.#4 privalova l. 18-3108-19\n"); printf("\n"); double x, b, a, y, s, t ; printf("x="); scanf("%lf", & x); printf("b="); scanf("%lf", & b); printf("a="); scanf("%lf", & a); printf("t="); scanf("%lf", & t); y=pow(exp, -b*t)*sin(a*t+b)-sqrt(abs(b*t + a)); s=b*sin(a*double(t)*cos(a*t))-1; printf("y=%l.4f\n", y); printf("s=%l.4f\n", s); printf("press and key"); getch(); }

Информатика

Ответы

leeteukism

:int main()

{

printf("L.r.#4 Privalova L. 18-3108-19\n");

printf("\n");

double x,b,a,y,s,t ;

printf("x=");scanf("%lf",&x);

printf("b=");scanf("%lf",&b);

printf("a=");scanf("%lf",&a);

printf("t=");scanf("%lf",&t);

y=pow(exp,-b*t)*sin(a*t+b)-sqrt(abs(b*t + a));

s=b*sin(a*double(t)*cos(a*t))-1;

printf("y=%l.4f\n",y);

printf("s=%l.4f\n",s);

printf("press and key");

getch(1);

}

Объяснение:Вроде тако не уверен

Вячеславовна_Сагитович
PROGRAM B01;

CONST
    max = 11;
TYPE
    vector = array[1..max]of integer;
VAR
    M, I, K:vector;
    j:byte;

{ Массивы I,K предварительно реорганизовать следующим образом: на первом
месте, в данных массивах должен стоять элемент с минимальным значением}
procedure reorganize_vector(var vt:vector);
var   i, j:byte;
      min, tmp:integer;
      
begin
  // вначале ищем минимальный элемент и запоминаем его место в массиве
  j:=1;//
  min:=vt[1];//назначаем наименьшим - первый элемент
  for i:=2 to max do
    if (min>vt[i]) then begin
      min:=vt[i];
      j:=i;//индекс наименьшего числа
    end;
    
  // теперь меняем местами первый элемент массива с наименьшим числом
  tmp := vt[1];//запоминаем значение первого элемента
  vt[1] := min;//меняем его на наименьший элемент
  vt[j] := tmp;//на место наименьшего ставим значение из первого элемента
end;

// процедура для вывода массива на экран
procedure print_vector(var vt:vector);
var j:byte;
begin
  for j:=1 to max do
    write(vt[j]:6);
  writeln(' ');
end;

BEGIN
  writeln('Дано:');

  //заполняем массивы случаынйми данными
  randomize;
  for j:=1 to max do begin
    I[j]:=random(-128,127);  
    K[j]:=random(-128,127);  
  end;

  //выводим их на экран
  write('массив I[',max,']: ');
  print_vector(I);
  write('массив K[',max,']: ');
  print_vector(K);

  writeln(' ');
  writeln('Реорганизовать массивы так, чтобы на первом месте ');
  writeln('должен стоять элемент с минимальным значением');

  reorganize_vector(I);
  reorganize_vector(K);

  write('массив I[',max,']: ');
  print_vector(I);
  write('массив K[',max,']: ');
  print_vector(K);

  writeln(' ');
  writeln('Сформировать массив М[',max,'], элементы которого вычисляются');
  writeln('по формуле M[j] = I[j] + K[j]');

  for j:=1 to max do
    M[j] := I[j] + K[j];

  write('массив M[',max,']: ');
  print_vector(M);
END.

На паскале написать программу с подпрограммой. дано: массивы i(11), k(11). сформировать массив м (11
dailyan539
целый целый R := A + B
тип результата: целый

целый целый R := A - B
тип результата: целый

целый целый R := A * B
тип результата: целый 

целый целый R := A / B
тип результата: вещественный

целый целый A > B
тип результата: логический (true/false)

целый целый A < B
тип результата: логический (true/false)

вещественный вещественный R := A + B
тип результата: вещественный

вещественный вещественный R := A - B
тип результата: вещественный

вещественный вещественный R := A * B
тип результата: вещественный

вещественный вещественный R := A / B
тип результата: вещественный

вещественный вещественный A > B
тип результата: логический (true/false)

вещественный вещественный A < B
тип результата: логический (true/false)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Исправить ошибки в программе у=e^-bt*sin(at+b) - sqrt|bt+a|; s=b*sin(at^2cos(at))-1 #include #include #include #define _use_math_defines //лаб.работа 4 студента гр.3108 //привалова любовь //вариант 18 int main() { printf("l.r.#4 privalova l. 18-3108-19\n"); printf("\n"); double x, b, a, y, s, t ; printf("x="); scanf("%lf", & x); printf("b="); scanf("%lf", & b); printf("a="); scanf("%lf", & a); printf("t="); scanf("%lf", & t); y=pow(exp, -b*t)*sin(a*t+b)-sqrt(abs(b*t + a)); s=b*sin(a*double(t)*cos(a*t))-1; printf("y=%l.4f\n", y); printf("s=%l.4f\n", s); printf("press and key"); getch(); }
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

missimeri
arutchevben64
amayonova
Сергеевна-Пузанов
Larisa-0888716
galinaobraz
Avolohova
ivan-chay19
fab2004
ooomedray4
kurmaleeva
nikolavlad
Тариелович871
alfastore4
Ulianev77