Татьяна-Мария
?>

Составьте программу которая позволяет ввести строку s и вывести каждое слово с новой строки.строка s состоящую из двух слов разделённых пробелом

Информатика

Ответы

dearmaria

11 в 10 СС = 1011 в 2 СС

11 в 10 СС = 13 в 8 СС

11 в 10 СС = В в 16 СС

Объяснение:

11 / 2 = 5 + остаток 1

5 / 2 = 2 + остаток 1

2 / 2 = 1 + остаток 0

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

11 в 10 СС = 1011 в 2 СС

11 / 8 = 1 + остаток 3

1 / 8 = 8 + остаток 1

записываем остатки снизу вверх

11 в 10 СС = 13 в 8 СС

11 / 16 = + остаток 11

записываем остатки снизу вверх

11 в 10 СС = В в 16 СС

В качестве цифр шестнадцатеричной системы счисления обычно используются цифры от 0 до 9 и латинские буквы от A до F.

A₁₆ = 10₁₀ B₁₆ = 11₁₀ C₁₆ = 12₁₀ D₁₆ = 13₁₀ E₁₆ = 14₁₀ F₁₆ = 15₁₀

jagerlayf

a = input()

mas = []

answer = ""

test01 = "Incorrect"

test02 = "Incorrect"

def check():

   global mas

   global answer

   global test01

   global test02

   

   

   #Bad, but this test01 deleted

   

   

   #Second step for check

   for infinity in range(100):

       for i in range(len(mas)):

           try:

               m = i + 1

               if mas[i] == "[" and mas[m] == "]" or mas[i] == "{" and mas[m] == "}" or mas[i] == "(" and mas[m] == ")":

                   del mas[i]

                   del mas[i]

           except:

               pass

       if len(mas) == 0:

           test02 = "Correct"

           break

       else:

           test02 = "Incorrect"

   #End testing

   if test02 == "Correct":

       answer = "correct"

   else:

       answer = "incorrect"

for i in range(len(a)):

   if a[i] == "{":

       mas.append(a[i])

   if a[i] == "[":

       mas.append(a[i])

   if a[i] == "(":

       mas.append(a[i])

   if a[i] == "}":

       mas.append(a[i])

   if a[i] == "]":

       mas.append(a[i])

   if a[i] == ")":

       mas.append(a[i])

del a

del i

check()

print(answer)

Объяснение:

Благодарности не требую, все ради Вас отметить как лучшее решение

10/10

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая позволяет ввести строку s и вывести каждое слово с новой строки.строка s состоящую из двух слов разделённых пробелом
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

blizzardtap641
adman7
Designer
sveta1864
annashersheva
schernov
Lavka2017
kristinmk
lpcck2212
galinazajceva781
ooo-helpvet44
Ирина
dpolkovnikov
lazu8375
metrikajulia
▲