Fedorova_79166180822
?>

Контрольная работа по информатике 7 класс, решите пример1. дано число х определить, является ли оно четным program name ; uses crt; var x: integer; begin clrscr; write ('x'); read(x) if x mod 2=0 then writekn ('да') else writeln ('нет' readkey; end. формулы для нахождения суммы и кол-ва: s=0, k=0, p= 1, s=s+a, k=k+1, p=p*a пример2. дано три числа. найти сумму чистел кратных 3 programe name uses crt; var a, b, c, s; integer; begin clrsccr; write ('b='): read (b) write ('c='); read(c) write ('a=') read(a) s: =0 if a mod 3=0 then s: =s+a if a mod 3=0 then s: =s+b if a mod 3=0 then s: =s+s writeln('s=', s) readkey; end : 1 дано три числа найти а)произведение чисел меньше 15ти б)кол-во чисел кратных 7ми в) сумму чисел оканчивающихся на 9 2. написать программу нахождения площади трапеции 3. определить является ли число кратным 5ти

Информатика

Ответы

akrivoz
Объект в программировании — некоторая сущность в виртуальном пространстве, обладающая определённым состоянием и поведением, имеющая заданные значения свойств (атрибутов) и операций над ними (методов) [1]. Как правило, при рассмотрении объектов выделяется то, что объекты принадлежат одному или нескольким классам, которые определяют поведение (являются моделью) объекта. Термины «экземпляр класса» и «объект» взаимозаменяемы. [2]

Объект, наряду с понятием класс, является важным понятием объектно-ориентированного подхода. Объекты обладают свойствами наследования, инкапсуляции и полиморфизма [1].
Игоревна
Первое задание:

Вам нужно только написать ввод и вывод, формула уже написана.

Код (Python 3):

x, y, z = map(int, input().split())

u=(max(x,y,z) - min(x,y,z))/(max(x,y,z)+min(x,y,z))

print(u)

Пример ввода 1:

1 1 1

Пример вывода 1:

0.0

Пример ввода 2:

3 2 1

Пример вывода 2:

0.5

Второе задание:

Находим максимальное число, и если текущее число не оно, на него можно умножать. Можно использовать список, так решение будет короче, я использую три переменные x, y, z.

Код (Python 3):

x, y, z = map(int, input().split())

max_xyz = max(x, y, z)

product = 1

if x != max_xyz:

   product *= x

if y != max_xyz:

   product *= y

if z != max_xyz:

   product *= z

print(product)

Пример ввода 1:

1 2 3

Пример вывода 1:

2

Пример ввода 2:

3 2 1

Пример вывода 2:

2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Контрольная работа по информатике 7 класс, решите пример1. дано число х определить, является ли оно четным program name ; uses crt; var x: integer; begin clrscr; write ('x'); read(x) if x mod 2=0 then writekn ('да') else writeln ('нет' readkey; end. формулы для нахождения суммы и кол-ва: s=0, k=0, p= 1, s=s+a, k=k+1, p=p*a пример2. дано три числа. найти сумму чистел кратных 3 programe name uses crt; var a, b, c, s; integer; begin clrsccr; write ('b='): read (b) write ('c='); read(c) write ('a=') read(a) s: =0 if a mod 3=0 then s: =s+a if a mod 3=0 then s: =s+b if a mod 3=0 then s: =s+s writeln('s=', s) readkey; end : 1 дано три числа найти а)произведение чисел меньше 15ти б)кол-во чисел кратных 7ми в) сумму чисел оканчивающихся на 9 2. написать программу нахождения площади трапеции 3. определить является ли число кратным 5ти
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nertman45
n-896458
jeep75
myglassi26
drozd228758
AlekseiMardanova
dimaaristov
Оксана Анна
Галстян874
Газинурович
mdclcompany
Konstantinovich alekseevna993
slazurnaya
info4632
mikchaylovaalex