mikek0906
?>

C-free . напишите программу, которая вводит строку и выводит ее, сокращая каждый раз на 1 символ до тех пор, пока в строке не останется 1 символ.

Информатика

Ответы

rodsher7740

#include <stdio.h>

#include <conio.h>

using namespace std;

int main()

{

char *Arr = new char[500];

printf("Entered string \n");

gets_s((char*)Arr, 500);

int count = 0;

for (int i = 0; Arr[i] != '\0'; i++)

{

 count++;

}

if (count == 1)

{

 return 0;

}

else

{

 for (int j = count; j>0; j--)

 {

  for (int k = 0; k < j; k++)

  {

   

   printf( "%c", Arr[k]);

  }

  printf("\n");

 }

}

delete[] Arr;

_getch();

return 0;

}

Объяснение:

cherry-sweet871435

В бутылке, стакане, кувшине и банке находится молоко, лимонад, квас и вода. Известно что вода и молоко не в бутылке, а сосуд с лимонадом находится между кувшином и сосудом с квасом, в банке - не лимонад и не вода. Стакан находится около банки и сосуда с молоком. Как распределены эти жидкости по сосудам?

Решение

Бутылка - НЕ вода, НЕ молоко (т.к. вода и молоко не в бутылке

Стакан - НЕ молоко (т.к. Стакан находится около сосуда с молоком)

Кувшин -НЕ лимонад, НЕ квас (т.к. а сосуд с лимонадом находится между кувшином и сосудом с квасом)

Банка - НЕ лимонад, НЕ вода, НЕ молоко (т.к. в банке - не лимонад и не вода., ...около банки и сосуда с молоком), остается, что в банке - квас

т.к. в бутылке и стакане НЕ молоко, значит молоко в кувшине

т.к. в бутылке НЕ вода, значит вода в стакане

значит остается, что в бутылке - лимонад

в банке - квас

молоко в кувшине

вода в стакане

в бутылке - лимонад

choia

1.Постановка задачи разрабатывается организацией, разработчиком программной продукции, на основании технического задания совместно с заказчиком. Главный исполнитель — это разработчик

2.Алгоритм-Последовательность действий, приводящих к результату.

Блок-схема- Графический записи алгоритма.

Исполнитель алгоритма-Человек, компьютер, автомат.

Язык программирования-Знаковая система для записи компьютерных программ.

Программа-Последовательность действий, приводящих к результату.

Объяснение:

Удачи тебе в учёбе!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C-free . напишите программу, которая вводит строку и выводит ее, сокращая каждый раз на 1 символ до тех пор, пока в строке не останется 1 символ.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

smook0695
aerendzhenova5
marani2
Yurevna_Kharkchinov1302
perovd8111
rimmatrotskaia303
svetegal
sadinuraliev263
irinalav2705745
Анатольевич-Лариса
Как появилось робо-сумо???
ilyushin-e
Kuzina Sergeevna
Дмитрий Бундин
sensenagon50
uuks2012