mmctriitsk
?>

Склавиатуры вводится строка, содержащая фамилию и имя. составьте программу, которая выводит фамилию и сокращённое имя.

Информатика

Ответы

D.Yu. Polina1703

var s:string;

i:integer;

begin

readln (s);

for i:=1 to Length(s)-1 do

if (s[i]=' ') and (s[i+1]<>' ') then write (copy(s,1,i+1),'.')

end.

Кольцова

8.   cos(x) - ((abs(x-2))/(sqrt(x)+3))+sqr(1+x)

9.   а = 10       b = 10       c = 20

Объяснение:

9.

а = 25       b = 16

пока условие (а + b) > 20 истинно   (да) выполнить

Действия в цикле:

1) а = а - 5

2) b = b - 2

c = а + b

а = 25       b = 16

(25 + 16) > 20       41 > 20       (да)

Действия в цикле:

1) а = 25 - 5 = 20

2) b = 16 - 2  = 14

а = 20       b = 14

(20 + 14) > 20       34 > 20       (да)

Действия в цикле:

1) а = 20 - 5 = 15

2) b = 14 - 2  = 12

а = 15       b = 12

(15 + 12) > 20       27 > 20       (да)

Действия в цикле:

1) а = 15 - 5 = 10

2) b = 12 - 2  = 10

а = 10       b = 10

(10 + 10) > 20       20 > 20       (нет)

Цикл не выполняется

а = 10       b = 10

c = а + b = 10 + 10 = 20

а = 10       b = 10       c = 20

skvorec3424

#define _USE_MATH_DEFINES

#include <iostream>

#include <math.h>

using namespace std;

int main()

{

 double a, b, alpha, s;             // объявления переменных

 setlocale(LC_ALL, "Russian");

 cout << "\nБольшее основание: ";   // ввод с клавиатуры

 cin >> a;

 cout << "\nМеньшее основание: ";

 cin >> b;

 cout << "\nУгол при большем основании: ";

 cin >> alpha;

 s = a * b / sin(alpha * M_PI / 180);  // расчет площади трапеции , * M_PI / 180 для перевода градусов в радианы

 cout << "\nПлощадь трапеции = " << s;

}

Объяснение:

#define _USE_MATH_DEFINES

#include <math.h>

эти две строки для M_PI, можно просто заменить на 3.14

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Склавиатуры вводится строка, содержащая фамилию и имя. составьте программу, которая выводит фамилию и сокращённое имя.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Liliya1106
ЕлизаветаВладимирович
sergei-komissar8475
themolodoy
chumakanna17
mir5552
thecoffeeowl
Dimston134877
Поликарпова-Мазурова
Viktorovna
Vos-sv
Galinagol559
potemkin77
moonligh3560
charlie79
▲