patersimon1
?>

Язык Паскаль. Напишите программу, которая моделирует работу следующего автомата. Автомат получает на вход трехзначное число и строит новое число следующим образом: 1) вычисляются суммы первой и второй, затем - второй и третьей цифр; 2) эти суммы записываются в порядке не возрастания. Например, для числа 639 получаем суммы: 6 + 3 = 9; 3 + 9 = 12. Результат: 129 Напишите программу, которая реализует работу данного автомата

Информатика

Ответы

lukur2005

var N,a,b,c,s1,s2:integer;

begin

Writeln('Напишите трёхзначное число');

ReadLn(N);

a:= N div 100;

b:= N div 10 mod 10;

c:= N mod 10;

s1:= a+b;

s2:= b+c;

if s1<s2 then

write(s2,s1)

else

write(s1,s2);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык Паскаль. Напишите программу, которая моделирует работу следующего автомата. Автомат получает на вход трехзначное число и строит новое число следующим образом: 1) вычисляются суммы первой и второй, затем - второй и третьей цифр; 2) эти суммы записываются в порядке не возрастания. Например, для числа 639 получаем суммы: 6 + 3 = 9; 3 + 9 = 12. Результат: 129 Напишите программу, которая реализует работу данного автомата
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

airlineskozlova69
socofilesrus4
ВалентиновичСуриковна1104
Aнaлитикaлық мaшинaAнaлитикaлық мaшинa
Volkovapavel
sakalrip
Alyona
Igorevich1559
Olegovna Volkov
info40
terehin863
krtatiana69
hadzievamareta44
Bolshakova Shigorina
zu87zu87
dashasnegirva