smook0695
?>

Друзья, кто шарит в информатике, прогу в паскале надо (30 на дороге не валяются) составить программу. найти кол-во последовательных нечетных чисел (начиная с 1), сумма которых не превосходит 100.

Информатика

Ответы

titovass9

var k,s,i:Integer;

begin

while s<=100 do

begin

i:=i+1;

k:=k+1;

s:=s+(i*2-1);

end;

write(k-1)

end.

fialkaflowers77

===== PascalABC.NET =====

begin

 var (s, i, k) := (1, 0, 100);

 while s <= k do

 begin

   i += 1;

   s += 2 * i + 1

 end;

 if s > k then

   i -= 1;

 SeqGen(i + 1, i -> 2 * i + 1).Println  

end.

Вообще задача решается без всякого программирования. Обычная сумма арифметической прогрессии с разностью 2.

(2 · 1 + 2(n - 1)) · n / 2 ≤ 100

n² ≤ 100 → n ≤ 10. Можно взять 10 нечетных чисел от 1 и их сумма будет ровно 100: 1+3+5+7+9+11+13+15+17+19 = 100


Друзья, кто шарит в информатике, прогу в паскале надо (30 на дороге не валяются) составить программу
polotovsky
1. прикладное ПО, системное и операционные системы
2. ОС - комплекс управляющих и обрабатывающих программ, которые, с одной стороны, выступают как интерфейс между устройствами вычислительной системы и прикладными программами
3. Интерфейс, Диалоговый режим взаимодействия пользователя или оператора с ЭВМ, при котором происходит непосредственный и двухсторонний обмен информацией, командами или инструкциями между человеком и ЭВМ.
4. Системой программирования называется комплекс программ, предназначенный для автоматизации программирования задач на ЭВМ . Предназначены для разработчиков ПО и системных программистов.
lechocolat

1. прикладное ПО, системное и операционные системы 
2. ОС - комплекс управляющих и обрабатывающих программ, которые, с одной стороны, выступают как интерфейс между устройствами вычислительной системы и прикладными программами 
3. Интерфейс, Диалоговый режим взаимодействия пользователя или оператора с ЭВМ, при котором происходит непосредственный и двухсторонний обмен информацией, командами или инструкциями между человеком и ЭВМ. 
4. Системой программирования называется комплекс программ, предназначенный для автоматизации программирования задач на ЭВМ . Предназначены для разработчиков ПО и системных программистов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Друзья, кто шарит в информатике, прогу в паскале надо (30 на дороге не валяются) составить программу. найти кол-во последовательных нечетных чисел (начиная с 1), сумма которых не превосходит 100.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olgusikok
Анастасия Елена
agitahell149
uvarovig
skalegin68
Gesper63
karpov68
Ермакова Ирина674
olyavoznyak
fakelel
artem
troian07
Тимур Андраниковна634
is926582086060
evsmorodina