Lorik-lorik29
?>

Написать программу на языке с++(со всеми объяснениями)написать функцию-процедуру, которая принимает в качестве аргументов целочисленный массив и две переменные a и b. функция должна вычислять количество элементов массива, значения которых лежат в диапазоне от a до b. это количество сохраняет в переменной-аргументе a. в b сохраняет количество элементов, не в диапазон.​

Информатика

Ответы

Домрачев

#include <iostream>

#include <time.h>

using namespace std;

pair<int, int> arr_to_range_and_save_the_number_of_elements(int* arr,int n, int a, int b) {

int count = 0;

for (size_t i = 0; i < n; i++) {

 if (arr[i] >= a && arr[i] <= b) {

  count++;

 }

}

a = count;

b = n - a;

return make_pair(a, b);

}

int* input_arr_auto(int* arr, int n) {

for (size_t i = 0; i < n; i++) {

 arr[i] = rand() % 200 - 100;

}

return arr;

}

int* input_arr(int* arr, int n) {

for (size_t i = 0; i < n; i++) {

 cin >> arr[i];

}

return arr;

}

void print_arr(int* arr, int n) {

for (size_t i = 0; i < n; i++) {

 cout << arr[i] << " ";

}

cout << endl;

}

int main()

{

setlocale(LC_ALL, "Russian");

srand(time(NULL));

int n;

int a, b;

cout << "Введите количество элементов массива: ";

cin >> n;

pair<int, int> pair_a_b;

int* arr = new int[n];

arr = input_arr_auto(arr, n);

print_arr(arr, n);

cout << "Введите a: ";

cin >> a;

cout << "Введите b: ";

cin >> b;

pair_a_b = arr_to_range_and_save_the_number_of_elements(arr, n, a, b);

cout << "Количество элементов, входящих в радиус: " << pair_a_b.first << endl;

cout << "Количество элементов, не входящих в радиус: " << pair_a_b.second;

}

Yelena-Svetlana

#include <iostream>

using namespace std;

void foo (int a[], int n, int& b, int& c)

{

   // мы не можем в С++ определить размер массива

   // поэтому вынуждены ее передавать в качестве параметра,

   // либо использовать специальный класс array

   int low = b, high = c;

   b = c = 0;

   for(int i = 0; i < n; i++)

       if((a[i] >= low) && (a[i] <= high))

           b++;

       else

           c++;

}

int main()

{

   int n;

   srand(time(0));

   cout << "Число элементов в массиве? ";

   cin >> n;

   int a[n];

   for(int i = 0; i < n; i++)

   {

       a[i] = rand() % 199 - 98;

       cout << a[i] << " ";

   }

   cout << "\nУкажите верхнюю и нижнюю границы для отбора: ";

   int b, c;

   cin >> b >> c;

   foo(a, n, b, c);

   cout << "Элементов в интервале: " << b << ", вне интервала: " << c;

   return 0;

}


Написать программу на языке с++(со всеми объяснениями)написать функцию-процедуру, которая принимает
buleckovd8724
//Блок-схемы в приложении
//Pascal ABC.NET v3.0 сборка 1111

//1
Var
 a,p,s:real;
begin
readln(a);
p:=a*4;
s:=a*a;
writeln('P=',p);
writeln('S=',s);
end.

//2
Var
 a,b:integer;
begin
 read(a,b);
 if a>b then writeln(b);
 if a=b then writeln('=');
 if a<b then writeln(a);
end.

{На этом и закончу всем, кто когда либо и чем либо поддерживал данный проект. Думаю, он ещё многим послужит в критический момент. И я говорю не только про "списать домашку". Счастливо оставаться, господин Alviko. Может, ещё увидимся.
Ваш, Глеб 'I3artle' Косырев}
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
club-pushkin
Простые числа от 5584 до 6654. В скобках после каждого я поставил его сумму цифр, а в конце строки количество четных:
5591(20), 5623(16), 5639(23), 5641(16), 5647(22), - 4
5651(17), 5653(19), 5657(23), 5659(25), 5669(26), - 1
5683(22), 5689(28), 5693(23), 5701(13), 5711(14), - 3
5717(20), 5737(22), 5741(17), 5743(19), 5749(25), - 2
5779(28), 5783(23), 5791(22), 5801(14), 5807(20), - 4
5813(17), 5821(16), 5827(22), 5839(25), 5843(20), - 3
5849(26), 5851(19), 5857(25), 5861(20), 5867(26), - 3
5869(28), 5879(29), 5881(22), 5897(29), 5903(17), - 2
5923(19), 5927(23), 5939(26), 5953(22), 5981(23), - 2
5987(29), 6007(13), 6011(09), 6029(17), 6037(16), - 1
6043(13), 6047(17), 6053(14), 6067(19), 6073(16), - 2
6079(22), 6089(23), 6091(16), 6101(08), 6113(11), - 3
6121(10), 6131(11), 6133(13), 6143(14), 6151(13), - 2
6163(17), 6173(17), 6197(23), 6199(25), 6203(11), - 0
6211(10), 6217(16), 6221(11), 6229(19), 6247(19), - 2
6257(20), 6263(17), 6269(23), 6271(16), 6277(22), - 3
6287(23), 6299(26), 6301(10), 6311(11), 6317(17), - 2
6323(14), 6329(20), 6337(19), 6343(16), 6353(17), - 3
6359(23), 6361(16), 6367(22), 6373(19), 6379(25), - 2
6389(26), 6397(25), 6421(13), 6427(19), 6449(23), - 1
6451(16), 6469(25), 6473(20), 6481(19), 6491(20), - 3
6521(14), 6529(22), 6547(22), 6551(17), 6553(19), - 3
6563(20), 6569(26), 6571(19), 6577(25), 6581(20), - 3
6599(29), 6607(19), 6619(22), 6637(22), 6653(20). - 3
Всего 120 простых чисел, из них 57 имеют четную сумму цифр.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке с++(со всеми объяснениями)написать функцию-процедуру, которая принимает в качестве аргументов целочисленный массив и две переменные a и b. функция должна вычислять количество элементов массива, значения которых лежат в диапазоне от a до b. это количество сохраняет в переменной-аргументе a. в b сохраняет количество элементов, не в диапазон.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ЕленаАлександровна381
Devaunka40
av52nazarov
s-food
Avdimov5
Владимирович_Роман
iralkap
annodomini1
vkurnosov20008
stasletter
Vladimirovna Viktorovna
Марина555
Стефаниди
diannaevaaa
arch5050