info664
?>

1.дан двумерный квадратный массив. найти номер строк, все элементы которых равны нулю 2. дан двумерный квадратный массив найти номера строк элементы в каждой из которых равны между собой 3. определите минимальный элемент двумерного массива напечатать номер срок содержащей максимальное число минимальных элементов если такие имеются

Информатика

Ответы

Vladimirovna1858

ответ:

10 эллемонтов массива вроде бы

snk7777202

ответ:

10 элементов

объяснение:

juliajd
Без проверки полагаем, что по заданным координатам точек можно построить треугольники.

//PascalABC.Net 3.0, сборка 1111
type
  Point=record
  x,y:double
  end;

function TriangleSquare(A,B,C:Point):double;
begin
  Result:=0.5*abs(A.x*(B.y-C.y)+B.x*(C.y-A.y)+C.x*(A.y-B.y))
end;

procedure GetPoint(c:char; var A:Point);
begin
  Write('Введите координаты точки ',c,': ');
  Readln(A.x,A.y)
end;

var
  A:array['A'..'F'] of Point;
  i:'A'..'F';
  s1,s2:double;
begin
  for i:='A' to 'F' do GetPoint(i,A[i]);
  s1:=TriangleSquare(A['A'],A['B'],A['C']);
  s2:=TriangleSquare(A['D'],A['E'],A['F']);
  if s1>s2 then Writeln('Площадь первого треугольника больше')
  else
    if s2>s1 then Writeln('Площадь второго треугольника больше')
    else Writeln('Площади треугольников равны')
end.

Тестовое решение:
Введите координаты точки A: -4 3.7
Введите координаты точки B: -6.3 0
Введите координаты точки C: 10.2 5.93
Введите координаты точки D: 7.143 8.1
Введите координаты точки E: -6 -3
Введите координаты точки F: 7.4 -5.7
Площадь второго треугольника больше
Devaunka40

1) Второе название термина "компьютерная графика?"(машинная)-8букв

2) Какой мультфильм в 1964 году, выполняя написанную программу решения дифференциальных уравнений, рисовала БЭСМ-4?(кошечка)-7букв

3)  Обычно компьютерную графику разделяют на векторную и растровую. Хотя обособляют ещё один ...тип представления изображений. Что это за тип? (фрактальный)-11букв

4) Название объекта, отдельные элементы которого наследуют свойства родительских структур. (фрактал)-7букв

5) Что управляет всеми визуальными преобразованиями в 3D-графике?(матрица)-7букв

6)Монитор-это матрица. Он состоит из строк и...?(столбцы)-7букв

7) Сколько видов матриц используется в компьютерной графике? (три)-3буквы

8) Объединение высококачественного изображения на экране компьютера со звуковым сопровождением-это? (мультимедиа)-11букв

9) Визуализация графики бывает растровая и..?(векторная)-9букв

визуализации это?(растр)-5букв

11) В 1963 году американский учёный создал аппарат, который позволял рисовать точки, линии и окружности цифровым пером. Назовите фамилию учёного. (Сазерленд)-9букв

12) Фамилия официального создателя первой комптютерной игры "Spacewar"? (Рассел)-6 букв.

13) Рисунки, выводимые последовательно на экран с определенной частотой, создают иллюзию. Иллюзию чего?(движения)-8букв

14) Средствами конструкторской графики можно получать плоские изображения. Такие как проекции и...?(сечения)-7букв

15) Название конференции проходящей в России по компьютерной графике?(Графикон)-8букв

 

p.s буквы указаны для удобства чертежа(если вы такой будете создавать).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.дан двумерный квадратный массив. найти номер строк, все элементы которых равны нулю 2. дан двумерный квадратный массив найти номера строк элементы в каждой из которых равны между собой 3. определите минимальный элемент двумерного массива напечатать номер срок содержащей максимальное число минимальных элементов если такие имеются
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

АминаИван
Svetlana ALLA
borisov
Kalashnikova
archala
olesyadeinega41
Альберт Татьяна
Манько_Панферов
Lesnova_Kiseleva730
Nadegdasb
Некрасов Валентина1097
gennadevna
Бернард pokerman
MDubovikov73
Павел