Манько_Панферов
?>

Хелп, умоляю..написать программу для подсчёта количества чётных и нечётных цифр любого числа( в паскале), .​

Информатика

Ответы

MikhailSvetlana

var

   a, chet, nechet : integer;

   

begin

   write('введите число: ');

   readln(a);

   while a > 0 do begin

       if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;

       a := a div 10;

   end;

   writeln('четных: ', chet);

   writeln('не четных: ', nechet);

end.

программа считает 0 как четное число. Если нужно что бы 0 не учитывался при подсчете то необходимо строку:

if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;

заменить на:

if a mod 10 <> 0 then if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;

ukkavtodor6
Одно и то же понятие может быть (за исключением единичных понятий и категорий предельно широких понятий) как видовым, так и родовым одновременно в зависимости от того, по отношению к какому понятию оно рассматривается. Так, понятие «суждение» является видовым по отношению к понятию «логическая форма» (формы мышления) и родовым по отношению к понятию «частное суждение».  Взаимосвязь видовых и родовых понятий отображает в сознании объективно существующую взаимосвязь рода и вида в природе и обществе.
Shpunt-86
1)Код — правило (алгоритм) сопоставления каждому конкретному сообщению строго определённой комбинации символов (знаков) (или сигналов). Кодом также называется отдельная комбинация таких символов (знаков) —слово.
В общем: код это набор каких-либо определенных символов  
2)Процесс преобразования сообщения в комбинацию символов в соответствии с кодом называется кодированием. 
Это замена, допустим, букв на символ(код)
3)процесс восстановления сообщения из комбинации символов называется декодированием. Процесс наоборот, т.е из символов(кода) возвращаем в буквы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Хелп, умоляю..написать программу для подсчёта количества чётных и нечётных цифр любого числа( в паскале), .​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

flerbuket332
Сумарокова
Наталья286
Ивановна_Маликова1549
Aksinya1036
Александра Викторович531
100 нарисовать замок в паскаль абс ​
ksv89
Аврамец1911
webotryvclub21
tvtanya80
Владислав1246
juli19657
ukkavtodor6
zurabghiendzhoian886
a580028r
▲