ninaandreeva3179
?>

Составьте программу, которая по выбору пользователя возводит введенное с клавиатуры целое число в квадрат, определяет его абсолютную величину или извлекает квадратный корень числа. в программе следует предусмотреть вывод сообщений об ошибке, если пользователь попытается извлечь квадратный корень из отрицательного числа. использовать стандартные функции abs, sqr, sqrt. пы.сы.составить в pascal

Информатика

Ответы

vdk81816778

Еще одно очень красивое и очень странное решение через словари.

n = int(input())

print({1<=n<=4: "Начальная школа",

     5<=n<=9: "Среднее звено",

     10<=n<=11: "Старшее звено"}[True])

Здесь мы создаем неименованный словарь, который в качестве ключа использует условное выражение, а в качестве значения - соответствующую этому выражению строку.

Когда мы тут же передаем ему в качестве ключа True, словарь начнет проверять ключи и вернет именно то значение, у которого выражение-ключ было истинным.

Olesyamilenina8

Объяснение:

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

srand(time(NULL));

int m, n;

cin >> m >> n;

if (m <= 0 || n <= 0) return 0;

int** arr = new int* [m];

for (int i = 0; i < m; i++)

{

 arr[i] = new int[n];

}

cout << endl;

for (int i = 0; i < m; i++)

{

 for (int j = 0; j < n; j++)

 {

  arr[i][j] = rand() % 11 - 5;

  cout.width(3);

  cout << arr[i][j];

 }

 cout << endl;

}

cout << endl;

int belowZero = 0;

for (int i = 0; i < m; i++)

{

 int sum = 0;

 for (int j = 0; j < n; j++)

 {

  sum += arr[i][j];

 }

 if (sum < 0) belowZero++;

}

cout << "  Answer: " << belowZero << endl;

for (int i = 0; i < m; i++)

{

 delete[] arr[i];

}

delete[] arr;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая по выбору пользователя возводит введенное с клавиатуры целое число в квадрат, определяет его абсолютную величину или извлекает квадратный корень числа. в программе следует предусмотреть вывод сообщений об ошибке, если пользователь попытается извлечь квадратный корень из отрицательного числа. использовать стандартные функции abs, sqr, sqrt. пы.сы.составить в pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

сузанна_Людмила
ТигранКалмыкова
Lenuschakova1982316
sotrudnik3
mail9
kzhgutova
eisakov86
sergeykvik13
gilmore886173
Карапетян
tigo1
NarekAlekseevich779
Каныбек698
Раисовна878
julkamysh9