Ивлев1508
?>

Python питон. написать программу, которая должна вывести на экран максимальное произведение 2-х различных элементов последовательности, кратное 6.

Информатика

Ответы

belegaj98
1. 2 Массивы объявляются тем же оператором, что и обычные переменные
2. Не корректный вопрос: индекс - это обращения к определенному элементу массива, а у самого массива индекса нет. В вариантах ответа ничего похожего на это нет.
3. 4 Массивы заполняются теми же операторами, что и обычные переменные
4. 1 Есть такой ввода в бейсике - конструкция READ DATA
5. 1 Выведется четвертый элемент массива, т.к. нумерация идет с нуля, и первый имеет номер 0, второй - 1, третий - 2, а четвертый - номер 3, который и запрашивается в выражении А(3)
Nikolai_oksana
Что касается конкретной программы
1. Описываем нужные нам переменные - это будут стороны прямоугольника a и b. Поскольку нигде ничего о размерах сторон не сказано, придется предположить, что они не обязательно будут целыми , мы опишем эти переменные, как вещественные (real), что позволит работать и с нецелыми значениями.
2. Из геометрии нам известны формулы периметра прямоугольника P=2 x (a+b) и площади прямоугольника S=a x b. Можно описать переменные P, S (тоже real), но смысла в этом нет, поскольку значения P и S нужны только для вывода результатов, так что проще написать нужные выражения непосредственно в операторе вывода.
3. Итак, с описанием переменных закончили, можно начинать основную программу ключевым словом begin. И сразу же пишем к нему завершающий end с точкой на конце - таковы правила языка Паскаль. Вся программа размещается между двумя этими ключевыми словами.
4. Сначала организуем ввод. Это два оператора. Первый оператор выводит так называемое "приглашение" - сообщает о том, что нужно ввести. Второй оператор - это сам ввод.
5. А теперь, как было сказано выше, организуем вывод результатов. Все это сделает один оператор вывода. Программа готова!

var
  a, b: real;

begin
  Write('Введите стороны прямоугольника: '); Readln(a, b);
  Writeln('Периметр равен ', 2 * (a + b), ', площадь равна ', a * b)
end.

Тестовое решение:
Введите стороны прямоугольника: 4 3.16
Периметр равен 14.32, площадь равна 12.64

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python питон. написать программу, которая должна вывести на экран максимальное произведение 2-х различных элементов последовательности, кратное 6.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

grishin
alfaduk24908
vera-classic75
vkurnosov20008
Косарев
Kalmikova1666
avto3132
Александр Джабраиловна1967
okison2847
parolmm
saryba
lugowskayatania2017
blackpoint2020273
petr2077