Prostofil200790
?>

Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве.массив должен вводиться во время работы программы. (pascal abc)

Информатика

Ответы

Latsukirina

const n=8;

var a: array[1..n] of integer;

c,i: integer;

f: boolean;

begin

f:=false;

writeln('введите массив из ',n,' элементов:');

for i:=1 to n do readln(a[i]);

write('введите число: ');

read(c);

for i:=1 to n do if a[i]=c then begin

f:=true;

break;

end;

if(f) then write('введенное число находится в массиве')

else write('введенное число не находится в массиве');

end.

vikgor45

#include <iostream>

#include <vector>

using namespace std;  

int main() {

   vector<int> ladder;

   int size, sum = 0;

   cin >> size;

   ladder.resize(size);

   for (int i = 0; i < size; ++i) {

       cin >> ladder[i];

   }

   for (int i = 0; i < size; ++i) {

       if (i + 1 < size && ladder[i] < 0) { // ladder[i] + ladder[i+1] < ladder[i + 1]

           sum += ladder[i + 1];

           ++i;

       }

       else {

           sum += ladder[i];

       }

   }

   cout << sum;

}

Дмитрий192

// кстати, а откуда задачки?

#include <iostream>

#include <string>

using namespace std;

int counter = 0;

int answer(string s, int l, int n, int length) {

   for (char ch = '0'; ch < length + '0'; ++ch) {

       if (ch == '0' && l && s[l - 1] == '0')

           continue;

       if (l + 1 < n)

           answer(s + ch, l + 1, n, length);

       else

           ++counter;

   }

   return counter;

}

int main() {

   int n, length;

   cin >> n >> length;

   cout << answer("", 0, n, length);

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве.массив должен вводиться во время работы программы. (pascal abc)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sleek73
westgti77105
gorsimonyan4
makovei78
starabanov
tatur-642789
stsnab
Anait_Natalya451
znaberd786
Вера1072
Milovidova
Екатерина1369
abakas235
parabolaspb
Ерцкин_Овечкина391