kogakinoa
?>

Составить программу сложения, которая находит сумму 10 целых чисел, вводимых с клавиатуры

Информатика

Ответы

romolga3580

Объяснение:

program z1;

var a,b,c,d,e,f,g,e,h,j,s:integer;

begin

read(a,b,c,d,e,f,g,e,h,j);

s:=a+b+c+d+e+f+g+e+h+j;

write(s);

end.

gbg231940

Для записи кода используется 14 букв разного регистра, всего их получается 28.

2 ** 1 = 2

2 ** 2 = 4

2 ** 3 = 8

2 ** 4 = 16

2 ** 5 = 32

Для записи символа нам хватит пяти бит.

Если личный код состоит из 20 букв, для его записи нам потребуется 20 * 5 байт= 100 бит.

Байт = 8 бит. Чтобы записать код необходимо 100 / 8 = 12.5 байт

По условию, он записывается на минимальном целом кол-ве байт. округляем необходимое для записи место в большую сторону и получим 13 байт.

13 байт занимает личный код сотрудника

Код подразделения - целое четырёхзначное число. Чтобы записать число от 1000 до 1999 как двоичное, нужно чтобы кодировка вмещала 1000 значений. (не написано что каждая цифра кодируется отдельно)

2 ** 10 = 1024

Для записи числа необходимо 10 бит. 10 бит это 1.25 байт, а значит для записи потребуется 2 байта.

2 байта занимает личный код сотрудника

30 байт - (13 байта на личный код + 2 байта на код подразделения) =

15 байт.

15 байт выделено для хранения дополнительных сведений об одном сотруднике.

losevev5619

Т.к. указано, что div - Это оператор, блок div в HTML разметке не подходит.

В математике есть оператор div - дивергенция. Однако вопрос задан в разделе информатики, поэтому предположу, что имеется ввиду оператор в каком-то языке программирования.

div в языке Паскаль является операцией целочисленного деления.

Т.е. в результате a div b будет получен результат деления a на b нацело (без остатка).

Примеры: 10 div 6 = 1 , 20 div 5 = 4 , 33 div 2 = 16

В языке Ассемблера для машин с архитектурой x86 инструкция div применяется для целочисленного деления. Выполняет деления значения в регистре AX, DX:AX, или EDX:EAX на операнд и помещает результат в AX, DX:AX, или EDX:EAX регистры

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу сложения, которая находит сумму 10 целых чисел, вводимых с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

DudukinSerega2507834
Хохлов
Михайлович1309
Бочкова_Елена203
stmr29
anatolevich1931
AnzhelikaSlabii1705
rmitin
NikolayGoncharov
mgrunova3966
Bella
appbiznessm
secretary
missmorozova2
mirdetzhuk79
▲