Хачатурович978
?>

(питон )напишите программу для расчета стоимости покупки в интернет магазине . с этой программы пользователь будет иметь возможность приобрести любое количество разнообразного it-оборудования , выбирая его из нескольких списков и в текстовом поле , записывая количество выбранного .

Информатика

Ответы

Владимировна Екатерина

#include <iostream>

#include <cmath>

using namespace std;

int main() {

 int B[17]; // создаём пустой массив

 srand(time(NULL)); // делаем так что бы функция rand() зависла от времени и не была постоянной

 for(int i = 0; i < 17; i++) { // заполняем массив случайными числами

   B[i] = rand() % 100;

 }

 for(int i = 0; i < 17; i++) { // выводим массив

   cout << B[i] << "\t";

 }

 cout << endl;

 for(int i = 0; i < 16; i++) { // ищем не парные числа и добавляем к ним значение последнего елемента

   if(B[i] % 2 != 0) {

     B[i] += B[16];

   }

 }

 for(int i = 0; i < 17; i++) { // выводим массив

   cout << B[i] << "\t";

 }

 cout << endl;

}

Объяснение:

oooviktoria17

#include <iostream>

#include <cmath>

using namespace std;

int main() {

 int B[16]; // создаём пустой массив

 srand(time(NULL)); // делаем так что бы функция rand() зависла от времени и не была постоянной

 for(int i = 0; i < 16; i++) { // заполняем массив случайными числами

   B[i] = rand() % 100;

 }

 for(int i = 0; i < 16; i++) { // выводим массив

   cout << B[i] << ", ";

 }

 cout << endl;

 int tmp = B[1]; // создаём временну переменную для хранения значения 2 элемента массива

 B[1] = B[14]; // присваиваем 2 элементу значение предпоследенго

 B[14] = tmp; // присваиваем предпоследенему элементу значение временной переменной

 for(int i = 0; i < 16; i++) { // выводим массив

   cout << B[i] << ", ";

 }

 cout << endl;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

(питон )напишите программу для расчета стоимости покупки в интернет магазине . с этой программы пользователь будет иметь возможность приобрести любое количество разнообразного it-оборудования , выбирая его из нескольких списков и в текстовом поле , записывая количество выбранного .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Savva1779
Elen-ti81459
iraira761
Радецкая264
lebedevevgen
remontsalarievo2
борисовна Елена78
is490
АннаМаргарита
kayrina
Вадим
Анна Марина1873
Хохлова Иванович
ivanovanata36937365
ninaandreeva3179