Задачи, связанные с определением количества информации, занимают довольно большое место как в общем курсе 9-11 классов, так и при итоговой аттестации разного типа.
Обычно решение подобных задач не представляет трудности для учащихся с хорошими к анализу ситуаций. Но большинство учеников поначалу путаются в понятиях и не знают, как приступить к решению.
Тем не менее, к 9-му классу учащиеся уже имеют определенный опыт решения задач по другим предметам (более всего – физика) с применением формул. Определить, что в задаче дано, что необходимо найти, и выразить одну переменную через другую – действия довольно привычные, и с ними справляются даже слабые ученики. Представляется возможным ввести некоторые дополнительные формулы в курсе информатики и найти общий стиль их применения в решении задач.
Оттолкнемся от одной из главных формул информатики – формулы Хартли N=2i. При ее использовании учащиеся могут еще не знать понятия логарифма, достаточно вначале иметь перед глазами, а затем запомнить таблицу степеней числа 2 хотя бы по 10-й степени.
При этом формула может применяться в решении задач разного типа, если правильно определить систему обозначений.
Выделим в системе задач на количество информации задачи следующих типов:
Количество информации при вероятностном подходе;
Кодирование положений;
Количество информации при алфавитном подходе (кодирование текста);
Кодирование графической информации;
Кодирование звуковой информации
Все задачи группы A (в случае, если мы имеем дело с равновероятными событиями) решаются непосредственно по формуле Хартли с ее привычными обозначениями:
N – количество равновероятных событий;
i – количество бит в сообщении о том, что событие произошло,
Причем в задаче может быть определена любая из переменных с заданием найти вторую. В случае если число N не является непосредственно числом, представляющим ту или иную степень числа 2, количество бит нам необходимо определить «с запасом». Так для гарантированного угадывания числа в диапазоне от 1 до 100 необходимо задать минимально 7 вопросов (27=128).
Решение задач для случаев неравновероятных событий в этой статье не рассматривается.
Для решения задач групп B-E дополнительно введем еще одну формулу:
Q=k*i
и определим систему обозначений для задач разного типа.
Для задач группы B значение переменных в формуле Хартли таково:
i – количество «двоичных элементов», используемых для кодирования;
N – количество положений, которые можно закодировать посредством этих элементов.
Так:
два флажка позволяют передать 4 различных сообщения;
с трех лампочек можно потенциально закодировать 8 различных сигналов;
последовательность из 8 импульсов и пауз при передаче информации посредством электрического тока позволяет закодировать 256 различных текстовых знаков;
и т.п.
Рассмотрим структуру решения по формуле:
Задача 1: Сколько существует различных последовательностей из символов «плюс» и «минус» длиной ровно в пять символов?
Дано: i = 5
Найти: N
Решение: N = 25
ответ: 5
Каждый элемент в последовательности для кодирования несет один бит информации.
Очевидно, что при определении количества элементов, необходимых для кодирования N положений, нас всегда интересует минимально необходимое для этого количество бит.
При однократном кодировании необходимого количества положений мы определяем необходимое количество бит и ограничиваемся формулой Хартли. Если кодирование проводится несколько раз, то это количество мы обозначаем как k и, определяя общее количество информации для всего кода (Q), применяем вторую формулу.
Задача 2: Метеорологическая станция ведет наблюдение за влажностью воздуха, результатом которых является целое число от 1 до 100%, которое кодируется посредством минимально возможного количества бит. Станция сделала 80 измерений. Какой информационный объем результатов наблюдений.
Дано: N = 100; k = 80
Найти: Q
По формуле Хартли i = 7 (с запасом); Q = 80 * 7 = 560
ответ: 560 бит
(Если в задаче даны варианты ответов с использованием других единиц измерения количества информации, осуществляем перевод: 560 бит = 70 байт).
Отметим дополнительно, что, если для кодирования используются нe «двоичные», а скажем, «троичные» элементы, то мы меняем в формуле основание степени.
Задача 3: Световое табло состоит из лампочек. Каждая из лампочек может находиться в одном из трех состояний («включено», «выключена» или «мигает»). Какое наименьшее количество лампочек должно находиться на табло, чтобы с его можно было передать 18 различных сигналов.
В данном случае N = 18, основание степени – 3. Необходимо найти i. Если логарифмы еще не знакомы, определяем методом подбора – 5. ответ: 5 лампочек
Далее рассмотрим решение задач на кодирование текстовой, графической и звуковой информации.
Здесь важно провести параллели:
Объяснение:
только в сети с полносвязной топологией для соединения каждой пары компьютеров имеется отдельная линия связи. во всех остальных случаях возникает вопрос о том, как организовать совместное использование линий связи несколькими компьютерами.
в вычислительных сетях используют как индивидуальные линии связи между компьютерами, так и разделяемые, когда одна линия связи попеременно используется несколькими компьютерами.
существуют различные технологии организации сети:
ethernet – (эзернет) – это наиболее популярная сетевая технология, используемая для создания локальных сетей. основной принцип, положенный в основу – случайный метод доступа к разделяемой среде передачи данных. в качестве такой среды может использоваться коаксиальный кабель, витая пара, оптоволокно или радиоволны. топология электрических связей –общая шина.
суть метода случайного доступа в следующем – информацию компьютер вначале убеждается, что сеть свободна, потом передает информацию. ее принимают все другие компьютеры. если информация предназначена им (они анализируют адрес назначения), то они ее копируют.
главное достоинство сети ethernet – – достаточно иметь сетевые адаптеры на компьютерах и кусок коаксиального кабеля.
token ring – кольцевая сеть, каждый узел кольца ожидает прибытие пакета информации адресованного ему.
однако в последние годы наметилась тенденция отказа от разделяемых сред передачи данных. это связано с низкой производительностью таких сетей. компьютеры подключаются индивидуальными линиями связи к специальному устройству - коммутатору. следует подчеркнуть, что связи между компьютерами остаются разделяемыми.
в сетях отказ от разделяемых линий связи объясняется техническими причинами: компьютеры могут затратить больше времени на переговоры о том, кому сейчас можно использовать линии связи, чем непосредственно на передачу данных по линии связи.
Поделитесь своими знаниями, ответьте на вопрос:
1.дан массив натуральных чисел. найти сумму элементов, кратных данному к. написать программу в питоне
Program num1;
Uses crt;
Var
a :array [1..100] of integer;
i,k,n, s : integer;
Begin
clrscr;
s:=0;
write('K=');readln(k);
write('N=');readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
if (a[i] MOD k)=0 then s:=s+a[i];
writeln('S=',s);
End.