missmorozova2
?>

Составить программу для вычисления суммы и среднего арифметического значения всех элементов заданного одномерного массива а, состоящего из 10-ти элементов. на языке с#

Информатика

Ответы

marysya60
Program n1;
var a,k,sum,x:integer;

begin
write('Введите число X: ');
readln(x);

sum:=0; k:=0;
writeln('Введите непустую последовательность целых чисел, которая оканчивается нулем:');
read(a);
while a <> 0 do 
begin 
 if a>x then sum:=sum+a; 
 if a mod 2 = 0 then k:=k+1; 
 read(a);
end;

writeln('Сумма всех чисел последовательности, больших числа X: ',sum);
writeln('Количество всех четных чисел последовательности: ',k);
end.

program n2;
var a,b,k:integer;

begin
writeln('Введите последовательность ненулевых целых чисел, которая оканчивается нулем:');
read(a);
while a<>0 do
begin 
 read(b); 
 if a*b<0 then k:=k+1; 
 a:=b;
end;

writeln(k,' раз(а) в введенной последовательности меняется знак');
end.
atamanov5
Лови
Флэш-память
Устройства, выполненные на одной микросхеме (кристалле) и не имеющие подвижных частей, основаны на кристаллах электрически перепрограммируемой флэш-памяти. Физический принцип организации ячеек флэш-памяти можно считать одинаковым для всех выпускаемых устройств, как бы они ни назывались. Различаются такие устройства по интерфейсу и применяемому контроллеру, что обусловливает разницу в емкости, скорости передачи данных и энергопотреблении.

Multimedia Card (MMC) и Secure Digital (SD) – сходит со сцены из-за ограниченной емкости (64 Мб и 256 Мб соответственно) и низкой скорости работы.
SmartMedia – основной формат для карт широкого применения (от банковских и проездных в метро до удостоверений личности). Тонкие пластинки весом 2 грамма имеют открыто расположенные контакты, но значительная для таких габаритов емкость (до 128 Мбайт) и скорость передачи данных (до 600 Кбайт/с) обусловили их проникновение в сферу цифровой фотографии и носимых МРЗ-устройств.
Memory Stick – “эксклюзивный” формат фирмы Sony, практически не используется другими компаниями. Максимальная емкость – 256 Мбайт, скорость передачи данных доходит до 410 Кбайт/с, цены сравнительно высокие.
CompactFlash (CF) – самый распространенный, универсальный и перспективный формат. Легко подключается к любому ноутбуку. Основная область применения – цифровая фотография. По емкости (до 3 Гбайт) сегодняшние CF-карты не уступают IBM Microdrive, однако отстают по скорости обмена данными (около 2 Мбайт/с).. USB Flash Drive
USB Flash Drive – последовательный интерфейс USB с пропускной Мбит/с или его современный вариант USB 2.0 с пропускной до 480 Мбит/с. Сам носитель заключен в обтекаемый компактный корпус, напоминающий автомобильный брелок. Основные параметры (емкость и скорость работы) полностью совпадают сCompactFlash, поскольку чипы самой памяти остались прежними. Может служить не только “переносчиком” файлов, но и работать как обычный накопитель – с него можно запускать приложения, воспроизводить музыку и сжатое видео, редактировать и создавать файлы. Низкое среднее время доступа к данным на Flash-диске – менее 2,5 мс. Вероятно, накопители класса USB Flash Drive, особенно с интерфейсом USB 2.0, в перспективе смогут полностью заменить собой обычные дискеты и частично – перезаписываемые компакт-диски, носители Iomega ZIP и им подобные.
PC Card (PCMCIA ATA) – основной тип флэш-памяти для компактных компьютеров. В настоящее время существует четыре формата карточек PC Card: Type I, Type II, Type III иCardBus, различающиеся размерами, разъемами и рабочим напряжением. Для PC Card возможна обратная совместимость по разъемам “сверху вниз”. Емкость PC Card достигает 4 Гб, скорость – 20 Мб/с при обмене данными с жестким диском.
Miniature Card (MC) – карточка флэш-памяти, предназначена в основном для карманных компьютеров, мобильных телефонов и цифровых фотокамер. Стандартная емкость составляет 64 Мбайт и больше.
Устройств хранения очень много, ты определись на какие именно будешь делать свой доклад или реферат

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для вычисления суммы и среднего арифметического значения всех элементов заданного одномерного массива а, состоящего из 10-ти элементов. на языке с#
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Serafim
sbelova
snopovajulia
nat5555
lagutkins
market-line5260
opal19575
Татьяна
Ye.Vadim
ivanova229
maximovpavel9114
Елена_Зайкин1665
Хрулёва
КутузоваМартенюк
novkatrina