Терентьева
?>

Дана последовательность p(n)=1/2; 1/; n(2)/2(n) (n в квадрате/2 в степени n) составить программу с использованием цикла while выводящую на экран номер первого члена последовательности меньшего вводимого числа и его значение на python

Информатика

Ответы

vadimkayunusov

1)

var a:array[1..20] of integer;
max,min,n,i:integer;
begin

randomize;
n:=20;
for i:=1 to n do a[i]:=random(150);
begin
min:=a[1];
for i:=1 to n do if a[1]>a[i] then min:=a[i];
end;
begin
max:=a[1];
for i:=1 to n do if a[1]<a[i] then max:=a[i];
end;
writeln(min);
writeln(max);
end.

 

 

2)

const n=5;
var x: array[1..n,1..n] of integer;
i,j,s: integer;
begin
randomize;
writeln('Matrisa:');
for i:=1 to n do
begin
for j:=1 to n do
begin
x[i,j]:=random(200);
write(x[i,j]:5);
end;
writeln
end;
j:=8;
for i:=1 to n do
begin
j:=j-1;
s:=s+x[i,(n+1-i)];
end;
writeln('Summa: ',s);
end.

artemka56rus

1)

var a:array[1..20] of integer;
max,min,n,i:integer;
begin

randomize;
n:=20;
for i:=1 to n do a[i]:=random(150);
begin
min:=a[1];
for i:=1 to n do if a[1]>a[i] then min:=a[i];
end;
begin
max:=a[1];
for i:=1 to n do if a[1]<a[i] then max:=a[i];
end;
writeln(min);
writeln(max);
end.

 

 

2)

const n=5;
var x: array[1..n,1..n] of integer;
i,j,s: integer;
begin
randomize;
writeln('Matrisa:');
for i:=1 to n do
begin
for j:=1 to n do
begin
x[i,j]:=random(200);
write(x[i,j]:5);
end;
writeln
end;
j:=8;
for i:=1 to n do
begin
j:=j-1;
s:=s+x[i,(n+1-i)];
end;
writeln('Summa: ',s);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана последовательность p(n)=1/2; 1/; n(2)/2(n) (n в квадрате/2 в степени n) составить программу с использованием цикла while выводящую на экран номер первого члена последовательности меньшего вводимого числа и его значение на python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alazaref
krispel9
nane2924329
Klicheva_Ermachenkova1536
tenvalerij
АнатольевичМиронова885
Евгеньевич Балиловна1398
ivanovk3599
juliaydodova
RozaAsadullina
Yevgenevich775
ak74-81
zabava-83
shelep19789
shkola8gbr