gunel1988alieva
?>

20 ! с клавиатуры вводится строка, состоящая из слов, разделенных пробелами. составьте программу, удаляющую лишние пробелы. пробел считается лишним, если он стоит в начале или в конце строки, следует за пробелом, стоит перед знаком препинания

Информатика

Ответы

puma802

===== PascalABC.NET =====

begin

 var p: set of char := ['-', '"', '''', ':', ';', ',',

     '?', '!', '(', ')', '.'];

 var s:= ReadlnString('Вводите:');

 var (a, i) := (s.ToWords, 0);

 while i < a.High do

 begin

   if a[i+1][1] in p then

   begin

     a[i] += a[i+1];

     a[i+1] := '';

     i += 2

   end

 else

   i += 1  

 end;

 s:= a.Where(p -> p.Length > 0).JoinIntoString;

 Writeln(s)

end.


20 ! с клавиатуры вводится строка, состоящая из слов, разделенных пробелами. составьте программу, уд
BogdanR106203

#define _CRT_SECURE_NO_WARNINGS

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

 int y;

 char buffer[80];

 cout << "Year = ";

 cin >> y;

 tm time_in;

 time_in.tm_sec = 0;  // second

 time_in.tm_min = 0;  // minute

 time_in.tm_hour = 0; // hour

 time_in.tm_mday = 1; // 1-based day

 time_in.tm_mon = 9;  // 0-based month

 time_in.tm_year = y - 1900; // year since 1900

 time_t time_temp = mktime (&time_in);   // Convert the local time to a calendar value.

 tm* time_out = localtime (&time_temp);  // Converts a time_t time value to a tm structure

 if (time_out->tm_wday > 0)              // if it is not Sunday, go to the next Sunday

   time_out->tm_mday += 7 - time_out->tm_wday;

 

 strftime(buffer, 80, "%d.%m.%Y", time_out);  // date formatting for output

 cout << "\nTeachers day is " << buffer << "\n";

}

Объяснение: explanations in the comments to the program

iivanov54
Самое простое, что умеет делать компьютер, – это сравнивать между собой числа и значения числовых выражений. для этого предназначены  операции отношения. кроме операций отношения есть ещё и  логические операции. они используются для того, чтобы из простых условий создавать сложные. особый класс операций представляют поразрядные операции. они выполняются над отдельными числа. в этом плане числа рассматриваются в двоичном представлении, например, 2 в двоичном представлении 10 и имеет два разряда, число 7 - 111 и имеет три разряда.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

20 ! с клавиатуры вводится строка, состоящая из слов, разделенных пробелами. составьте программу, удаляющую лишние пробелы. пробел считается лишним, если он стоит в начале или в конце строки, следует за пробелом, стоит перед знаком препинания
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ikhilovb76
alina-bas
Матвеев
larisau41
Vipnikavto58
Burov1446
Valerii276
makarov021106
evoque2014
savenko0109152
thebest59
chernova1exei862
Berezovskaya
taksa6444
sergeevna
▲