beliaeva2
?>

Дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите сумму всех чётных чисел, кратных 3.program z1; varch, s: integer; beginwriteln('введите последовательность натуральных чисел, оканчивающихся 0); readln(ch); s: =0; while ch< > 0 dobegin if not(odd(ch)) and (ch mod 3=0)then s: =s-ch: readln (ch) ; end; writeln (' s='s) ; end2.дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите минимальное число этой последовательности, исключая последний ноль. var min ch: integer ; begin writeln (' введите последовательность натуральных чисел, оканчивающихся 0'; )readln (ch) min: =ch ; while ch< > 0 dobegin if (ch0)then min : =ch : readln (ch) ; end; writeln ('min =', min) ; end . 1. дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите количество всех нечётных чисел, оканчивающихся цифрой 3.2. дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите максимальное число этой последовательности. ​

Информатика

Ответы

marat-dzhanibekov

program Z1;

var

 ch, s: integer;

begin

 writeln('введите последовательность натуральных чисел, оканчивающихся 0');

 readln(ch);

 s := 0;

 while ch <> 0 do

 begin

   if odd(ch) and (ch mod 10 = 3) then

     s := s + 1;

   readln(ch);

 end;

 writeln('s = ', s);

end.

*****************************************************

var

 max, ch: integer;

begin

 writeln(' введите последовательность натуральных чисел, оканчивающихся 0');

 readln(ch);

 max := ch;

 while ch <> 0 do

 begin

   if (ch > max) and (ch <> 0) then

     max := ch;

   readln(ch);

 end;

 writeln('max =', max);

end.


Дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите сумму всех чётных чисел
Дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите сумму всех чётных чисел
Ragim777hazarovich

Відповідь:

#include <iostream>

using namespace std;

const int size = 10;

void cinarr(int *arr,const int size){

int counter = 1;

for(int i = 0; i < size; i++){

 cout << "Введите " << counter << " елемент массива: ";

 cin >> arr[i];

 counter++;

}

}

void printarr(int *arr, const int size){

for(int i = 0; i < size; i++){

 cout << arr[i] << " ";

}

}

int expression(int *arr,const int size,int number){

int counternumber = 0;

for(int i = 0; i < size; i++){

 if(number == arr[i]){

  counternumber++;

 }

}

return counternumber;

}

int main(){

setlocale(LC_ALL , "Rus");

int number;

cout << "Введите число которое будем искать: ";

cin >> number;

int *arr = new int [size];

cinarr(arr,size);

printarr(arr,size);

cout << "\nТаких чисел в массиве: " << expression(arr,size,number) << endl;;

delete [] arr;

return 0;

}

Пояснення:


Написать программу, которая получает на 10 элементов и записывает их в массив. Также программа получ
Galkin683

Відповідь:

1.В текстовому процесорі Word передбачена можливість змінювати варіанти оформлення маркованих та нумерованих списків.

2.Вказані кнопки групи Абзац мають відповідно таке призначення: маркований список, нумерований список, багаторівневий список.

3.Розмістивши курсор у потрібному місці документа, слід увести спеціальні умовні символи, які визначають вид бажаного списку, і натиснути клавішу Пропуск

Одразу ж умовні символи перетворяться на відповідний маркер або номер.

Далі можна розпочинати введення першого елемента списку.

4.Відмінити нумерацію (маркування) після закінчення введення елементів списку можна повторним вибором кнопки списку або натиснення клавіші Backspace.

5.Двічі клацніть числа у списку. Текст не буде виділено.

Клацніть правою кнопкою миші номер, який потрібно змінити.

Натисніть кнопку Установити значення нумерування.

У полі Установити значення: за до стрілок змініть значення на потрібне число.

Пояснення:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите сумму всех чётных чисел, кратных 3.program z1; varch, s: integer; beginwriteln('введите последовательность натуральных чисел, оканчивающихся 0); readln(ch); s: =0; while ch< > 0 dobegin if not(odd(ch)) and (ch mod 3=0)then s: =s-ch: readln (ch) ; end; writeln (' s='s) ; end2.дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите минимальное число этой последовательности, исключая последний ноль. var min ch: integer ; begin writeln (' введите последовательность натуральных чисел, оканчивающихся 0'; )readln (ch) min: =ch ; while ch< > 0 dobegin if (ch0)then min : =ch : readln (ch) ; end; writeln ('min =', min) ; end . 1. дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите количество всех нечётных чисел, оканчивающихся цифрой 3.2. дана не пустая последовательность целых чисел, оканчивающаяся нулём. найдите максимальное число этой последовательности. ​
Ваше имя (никнейм)*
Email*
Комментарий*