vetviptime
?>

37 ! составить программу на pascal. условие: даны три стороны треугольника. вычислите площадь и периметр. ход решения: ввести три цифры - стороны треугольника и с форум нахождения площади и периметра треугольника найти их.

Информатика

Ответы

elenasnikitina84

var a,b,c,p,s: real;

begin

 write('Введите 1-ю сторону: '); readln(a);

 write('Введите 2-ю сторону: '); readln(b);

 write('Введите 3-ю сторону: '); readln(c);

 p:= a + b + c;

 s:=sqrt((p/2)*(p/2-a)*(p/2-b)*(p/2-c));

 writeln('Периметр = ', p);

 writeln('Площадь = ', s);

end.

valera850515

===== PascalABC.NET =====

begin

 var (a, b, c) := ReadReal3('Введите длины сторон через пробел:');

 var P := a + b + c;

 var p2 := P / 2;  // полупериметр

 var S := Sqrt(p2 * (p2 - a) * (p2 - b) * (p2 - c)); // ф-ла Герона

 Println('P =', P, '   S =', S)

end.


37 ! составить программу на pascal. условие: даны три стороны треугольника. вычислите площадь и пери
andyrvo

При автоматическом переводе могут возникнуть много проблем

в зависимости от контекста слова могут иметь разное значениеперевод пословиц, поговорок и прочих стандартных словосочетаний может не существовать на другом языке или может быть передан не верноотрицательные предложения могут перейти в положительныеигра слов часто непереводиманедостаток информации одного текста не может быть восполнен. Например в английском у глаголов нет родов, а в русском естьдругая причина потери смыслаэлектронный переводчик может не знать, как переводится слово или фраза, или не иметь всех вариантов перевода
thecoffeeowl
Const nx=30;var i,j,p,n:integer;A:array[1..nx,1..nx] of integer;d,Sn,min:real;begin p:=1;write('Введите размер матрицы');Read(n);for i:=1 to n do beginfor j:=1 to n do beginA[i,j]:=random(3)-2;write(A[i,j]:4);end;writeln;end;writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif i = j then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif (i= n -j +1) then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

37 ! составить программу на pascal. условие: даны три стороны треугольника. вычислите площадь и периметр. ход решения: ввести три цифры - стороны треугольника и с форум нахождения площади и периметра треугольника найти их.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Александровна1742
evoque2014
pelagia-kola2658
VladimirovnaSimonov
kuharchuks
kamimoza
Антон
av4738046
КалюкМарасанов1026
Fetyukov
garikman-flesh486
Print("8", "x", "9", "=", "72", sep"") ​
slitex
karpov68
iburejko7
Shishkinaanasta1997