l250sp70
?>

50 ! .в массиве из 15 вещественных чисел найти наибольший элемент и поменять его местами с последним элементом.нужно составить программу для visual basic for application (vbaзаранее огромное ​

Информатика

Ответы

aaltuxova16

program laba;

{$APPTYPE CONSOLE}

uses

 SysUtils,

 windows;

var

 a:array[1..15] of integer;

 i,imax,x:integer;

begin

SetConsoleoutputCP(1251);

 for i:=1 to 15 do

begin

writeln('Введите',i,'-й элемент');

readln(a[i]);

end;

imax:=1;

for i:=2 to 15 do

if a[i]>a[imax] then imax:=i;

x:=a[15];

writeln('максимальное число = ',a[imax],' его индекс= ',imax);

if imax=15 then write('Он последний, обмена нет');

else

  begin

  x:=a[imax];

  a[imax]:=a[15];

  a[15]:=x;

  writeln('Обмен максимального и последнего:');

  for i:=1 to 15 do

  write(a[i]:6:3,' ');

  end;

 

readln;

end.

Объяснение:

sokolskiy458

Sub Swap()

   Dim r As Range, A As Variant

   Dim i As Integer, im As Double, n As Integer, t As Double

   n = 15

   Set r = Range(Cells(1, 1), Cells(1, n))

   A = r

   im = 1

   For i = 2 To n

       If A(1, i) > A(1, im) Then

           im = i

       End If

   Next i

   t = A(1, im)

   A(1, im) = A(1, n)

   A(1, n) = t

   Set r = Range(Cells(2, 1), Cells(2, n))

   r = A

End Sub

На лист в ячейки А1 - О1 заносим исходные 15 чисел

На этот же лист через проект помещаем макрос и запускаем.

Результат будет в ячейках А2 - О2

Шеина

A = [] # создаем массив  

step = 3 #  создаем переменную , которая является началом нашего ряда  

while sum(A) < 15: # пока сумма нашего массива меньше 15 (sum - складывает все элементы нашего массива)

   A.append(step) # мы добавляем в  массив число

   step +=1 # и увеличиваем число в ряду на 1

print(sum(A)) # после выполнения цикла  выводим сумму  массива

A = [] # создаем массив  

step = 3 #  создаем переменную , которая является началом нашего ряда  

Num = int(input()) # просим у пользователя ввести число  

while sum(A) < Num: # пока сумма нашего массива меньше  (sum - складывает все элементы нашего массива)

   A.append(step) # мы добавляем в  массив число

   step *= 2 # умножаем шаг ряда на 2

print(sum(A)) # после выполнения цикла  выводим сумму  масиива  

Объяснение:

Матвеев

Частота процессора влияет на его производительность. На системной плате имеются разъёмы: USB, PS/2, VGA, HDMI, DVI, Enthernet порт, 3,5mm и т.д.

В оперативной памяти хранятся команды, константы, числа, коды и т.д.

Различие между CD и DVD во первых в их памяти. На CD диске всего 800мб, на DVD диске 4700мб (4,7гб) Ещё они отличаются толщиной дорожек

Энергонезависимую память целесообразно использовать на мобильных устройствах для того, чтобы снизить электропотребление устройства и продлить жизнь устройству.

Существуют ноутбуки. В отличие от стационарных компьютеров, они занимают меньше места, а также для полноценной работы ноутбука достаточно иметь лишь кабель питания, м то, только для зарядки встроенного аккумулятора. Но их компактность сказывается на из мощности. Они слабее стационарных компьютеров. Также существуют нетбуки. В отличие от ноутбуков, они занимают ещё меньше места. И это сказывается на их производительности. Они менее производительные, чем ноутбуки.

Не думаю, что ты напишешь на 5, но на 4 точно должен. Я старался :)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

50 ! .в массиве из 15 вещественных чисел найти наибольший элемент и поменять его местами с последним элементом.нужно составить программу для visual basic for application (vbaзаранее огромное ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

M10M11M12
Дмитриевич Бирковская69
avolodyaev
kolesnikovaen
Andei
Kushchenko-Monashev
kortikov77
Oslopova
Voronin-Albertovich
tabacoffee
Vasilevich Fokin
strelnikov-aa
Никита227
dailyan539
tumanowivan2015509
▲