Поделитесь своими знаниями, ответьте на вопрос:
1)определите значение переменной «a» после выполнения фрагмента алгоритма. 2)у исполнителя удвоитель две команды: 1. прибавь 1 2. умножь на 2 напишите программу из 4 команд, которая преобразует число 4 в число 36. ответ записывать как последовательность номеров команд, например программа 1121 преобразует число 2 в 9 1) 2+1=3; 1)3+1=4 ; 2)4*2=8 ; 1)8+1=9
int main()
{
int nn,kk;
printf("Enter peoples and -kk: ");
scanf("%d%d",&nn,&kk);
int n[nn];
int k = kk;
int sum, p, l = 0, i = 0, q = 0;
for(int i = 0; i < nn; i++)
{
n[i] = 1;
printf("%d ",n[i]);
}
printf("\n");
do{
sum = 0;
p = l;
q = 0;
for(int i = 0; i < nn; i++)
{
if(n[i])
{
sum++;
}
}
for(;q!=kk;)
{
if(i==nn) i = 0;
if(n[i])
{
p++;
q++;
}
if(q==kk)
{
n[i] = 0;
l = i;
}
i++;
}
for(int i = 0; i < nn; i++)
{
printf("%d ",n[i]);
}
printf("\n");
}while(sum>2);
for(int i = 0; i < nn; i++)
{
if(n[i])
{
printf("Last: %d#",i+1);
}
}
return 0;
}