olegtarasov1965
?>

Нужно решить в паскале. умоляю, от этого зависит итоговая оценка! напишите программу, которая сортирует по возрастанию все элементы массива с нечётными номерами, а все элементы с чётными номерами – по убыванию. нумерация элементов массива начинается с единицы.входные данныепервая строка содержит размер массива  n  . во второй строке через пробел   n  чисел – элементы массива. гарантируется, что  0 <   n  ≤ 1  .выходные данныепрограмма должна вывести все элементы отсортированного массива в одну строку, разделив их пробелами.​

Информатика

Ответы

printdecor

Графічний інтерфейс — це вигляд вікна програми, в якому для взаємодії людини й комп’ютера застосовуються графічні компоненти (вікна, меню, кнопки тощо).

Користувач має довільний доступ (за до клавіатури або миші) до екранних об’єктів — елементів інтерфейсу. За до мови програмування Python можна створювати програми з графічним інтерфейсом. Для цього в середовищі Python застосовується окремий вбудований модуль tkinter, який містить набір графічних компонентів для створення графічного інтерфейсу. Кожний графічний компонент — це об’єкт певного класу, що має властивості та методи.

Объяснение:

yfetyukov2

n = int(input())

arr = [[int(input()) for j in range(n)] for i in range(n)]

print('\n'.join([''.join([str(f'{i:4}') for i in row]) for row in arr]))

arr = list(zip(*arr))

print('\n'.join([''.join([str(f'{i:4}') for i in row]) for row in arr]))

№2

n = int(input())

k = int(input())

arr = [[int(input()) for j in range(n)] for i in range(n)]

for i in range(n):

   for j in range(n):

       if k == i:

           arr[i][j] = arr[i][j] / arr[i][i]

print('\n'.join([''.join([str(f'{i:4}') for i in row]) for row in arr]))

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно решить в паскале. умоляю, от этого зависит итоговая оценка! напишите программу, которая сортирует по возрастанию все элементы массива с нечётными номерами, а все элементы с чётными номерами – по убыванию. нумерация элементов массива начинается с единицы.входные данныепервая строка содержит размер массива  n  . во второй строке через пробел   n  чисел – элементы массива. гарантируется, что  0 <   n  ≤ 1  .выходные данныепрограмма должна вывести все элементы отсортированного массива в одну строку, разделив их пробелами.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ИП-Сысоев1628
борисовна Елена78
Sergei_Olga658
natalia-shelkovich
milanparipovic864
Голосова-Лобанов1555
gabramova
Татьяна1856
alexandergulyamov
Кочугурова
omigunova39
bulenbeiser
rusplatok
egamedicalbuh
turovvlad