KonovalovKonstantinovna1306
?>

Написать программу в которой вычисляется сумма десятков трёх целых чисел, больше 9. например, 3 числа: 12, 234, 4563, сумма десятков (2+3+6)=11

Информатика

Ответы

nadejdashin508

#summa vtorqh elementov s konca chisel, kotorqe bolshe 9 s proverkoj na 9

a=0

b=0

c=0

print("Vvedite celqe chisla bolshe 9\n")

while int (a) < 10:

   a = input("Vvedite pervoe chislo: ")

else:

   while int (b) < 10:

       b = input("Vvedite vtoroe chislo: ")

   else:

       while int (c) < 10:

           c = input("Vvedite tretje chislo: ")

a=str(a)[::-1]  #Perevodim v stroku i reversiruem

b=str(b)[::-1]  #t.k. nachinaem sleva napravo

c=str(c)[::-1]  #i tak legche vsego najti vtoroe chislo s konca

A=int(a[1])  #perevodim obratno v int dlja provedenija matem operacij nad nimi

B=int(b[1])  #element [1] i budet vtoroe chislo s konca

C=int(c[1])

if A==1:

   A=A+1

if B==1:

   B=B+1

if C==1:

   C=C+1

sum = A+B+C

print("Summa desjatkov = " + str(sum))

Объяснение:

Это на python, наверное далеко не самый корректный код, но задачу выполняет. Если я правильно понял, то например у числа 12 десятком будет 2? (Судя по заданию)  - если это не так, то надо всего лишь удалить весь блок проверки if (от if A==1: до C=C+1)


Написать программу в которой вычисляется сумма десятков трёх целых чисел, больше 9. например, 3 числ
Nikita_Lina1305
Денотатный граф - [от лат. denoto — обозначаю и греч. — пишу вычленения из текста существенных признаков ключевого понятия.

создания денотатного графа:
•Выделение ключевого слова или словосочетания
•Чередование имени и глагола в графе (именем может быть одно существительное или группа существительных в сочетании с другими именными частями речи; глагол выражает динамику мысли, движение от понятия к его существенному признаку)
•Точный выбор глагола, связывающего ключевое понятие и его существенный признак (глаголы, обозначающие цель — направлять, предполагать, приводить, давать и т. д. ; глаголы, обозначающие процесс достижения результата — достигать, осуществляться; глаголы, обозначающие предпосылки достижения результата — основываться, опираться, базироваться; глаголы-связки, с которых осуществляется выход на определение значения понятия)
•Дробление ключевого слова по мере построения графа на слова — "веточки"
•Соотнесение каждого слова — "веточки" с ключевым словом с целью исключения каких-либо несоответствий, противоречий и т. д.
Pona4ka93

1. можно выделить лишь три основных вида алгоритмов (для краткости далее будем называть их линейные, разветвляющиеся и циклические алгоритмы):

• линейной структуры,

• разветвляющейся структуры,

• циклической структуры.

Линейный алгоритм – алгоритм, в котором порядок действий фиксирован и каждое действие выполняется только один раз.

Разветвляющаяся структура алгоритм, при выполнении которого каждый раз последовательность действий может быть разная. Схема подобного алгоритма обязательно содержит хотя бы один блок (символ) "решение", который и обеспечивает разветвление вычислительного процесса.

Алгоритм циклической структуры – это алгоритм, в котором предусмотрено неоднократное выполнение одной и той же последовательности действий. На практике часто встречаются задачи, в которых одно или несколько действий бывает необходимо повторить несколько раз.

2. Блок-схема — рас тип схем (графических моделей), описывающих алгоритмы или процессы, в которых отдельные шаги изображаются в виде блоков различной формы, соединенных между собой линиями, указывающими направление последовательности.

3. Псевдоко́д — компактный, зачастую неформальный язык описания алгоритмов, использующий ключевые слова императивных языков программирования, но опускающий несущественные для понимания алгоритма подробности и специфический синтаксис.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в которой вычисляется сумма десятков трёх целых чисел, больше 9. например, 3 числа: 12, 234, 4563, сумма десятков (2+3+6)=11
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Linichuk
baeva-larisa8165
Назаров588
artashhovhan
Bella
Владислав-Аветисян217
Gor Anatolevich
Ruzalina_Svetlana1435
Gesper63
Исаченко Тераски1181
best00
rayman777
nikitavertiev98400
vdm4275
Андреевич-Екатерина1974